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2. Introducción 

PocketTopo es una aplicación para procesar y almacenar los datos de las topografías 
espeleológicas. Ha sido diseñada para funcionar en una PDA que utilice Windows Mobile, o en 
cualquier dispositivo que soporte el entorno .Net compacto. Por otro lado, está preparada para 
recibir directamente las mediciones topográficas desde un dispositivo electrónico de medida, a 
través de una conexión Bluetooth. Los datos pueden ser, además, introducidos manualmente, 
aunque la solución ideal es un dispositivo electrónico conectado. 

La representación de los datos ha sido optimizada para un dispositivo electrónico con brújula 
triaxial y clinómetro, como el DistoX. Admite un número ilimitado de mediciones auxiliares de 
contorno, tomadas en direcciones arbitrarias en cada estación topográfica. 

Una de sus principales ventajas consiste en que permite trazar directamente en la pantalla de 
la PDA, sobre la marcha, el dibujo de la cueva, pudiendo apoyarse en multitud de mediciones 
auxiliares para una mayor precisión. 

 

3. La interfaz de usuario 

Consiste, básicamente, en una barra de herramientas que contiene el menú principal y varios 
botones, además de un espacio principal en el centro de la pantalla, que ofrece tres posibles 
vistas: 

 

- Datos: (Data View) - Se trata de una tabla numérica con las mediciones topográficas. 

- Poligonal: (Map View) - Permite visualizar esquemáticamente la poligonal de la cavidad en 
conjunto. 

- Dibujo: (Sketch View) - Muestra el pasaje que se está topografiando en un momento 
dado y permite dibujar dos vistas: Planta (Outline) y alzado (Side View). 

 

    

 Datos Poligonal Dibujo 

   (planta) 
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3.1 Menú principal 

Contiene las funciones siguientes: 

 

Bluetooth: Muestra el submenú Bluetooth. 

 Bluetooth > Connect 

 Activa la conexión con el dispositivo de medición. Para ello es necesario tener 
correctamente configurado el puerto de enlace en la opción Port. 

 Bluetooth > Disconnect 

 Desactiva la conexión Bluetooth. 

 Bluetooth > Auto 

 Activa o desactiva automáticamente el modo de conexión. Estando activada, la PDA 
tratará de volver a conectar con el dispositivo de medición a intervalos regulares, en 
caso de que se interrumpa dicha conexión. 

 

Options (opciones): Muestra el submenú de las opciones de configuración, con varios 
comandos de configuración. 

 Options > Title Bar (barra superior) 

 Permite mostrar u ocultar la barra superior estándar de Windows Mobile. Cuando está 
oculta, el área útil de la pantalla aumenta ligeramente, pero el menú Inicio deja de 
estar accesible directamente. 

 Options > Smart (modo inteligente) 

 Activa o desactiva el “modo inteligente” (Smart). Cuando está activado, el programa 
reconoce automáticamente tres mediciones sucesivas prácticamente idénticas como una 
tirada de la poligonal topográfica principal. La opción Reverse determina si la medición 
es directa (en el sentido del avance) o inversa (en sentido salida). 

Options > Reverse (invertir) 

Determina el sentido por defecto de las mediciones que forman parte de la poligonal. 
Ese sentido es el aplicado por el programa en el modo “smart”, y por el comando Shot 
(visual) en el menú contextual de entrada de datos (véase más adelante). 

 Options > Units (unidades) 

 Permite seleccionar las unidades para edición y visualización de los datos. Los cambios 
en las unidades no afectan a los datos almacenados. 

 Options > Units > 360° 

 Fija la unidad angular en grados sexagesimales (circunferencia completa = 
360°). 
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 Options > Units > 400g  

 Fija la unidad angular en grados centesimales (circunferencia completa = 400g). 

 

 Options > Units > m 

 Fija la unidad de medida de distancias en metros. 

 Options > Units > Feet 

 Fija la unidad de medida de distancias en pies. 

 Options > Port (puerto) 

 Permite seleccionar el puerto serie para la conexión Bluetooth con el instrumento de 
medición. El puerto escogido debe coincidir con el puerto de salida serie (Outgoing 
Serial Port) en el Bluetooth manager (p.e. COM1). 

 Options > Port > None (ninguno) 

 No selecciona ningún puerto y desactiva la conexión Bluetooth. 

 Options > Port > COM0 - COM9 

 Asigna a la conexión Bluetooth con el dispositivo de medida un puerto 
determinado, entre COM0 y COM9. 

 

Actual trip… (sesión actual): Abre una ventana que permite inspeccionar y cambiar los 
ajustes correspondientes a la sesión topográfica en curso. Los ajustes se utilizarán para las 
nuevas mediciones. 

 

Calibration… (calibración): Abre la ventana de calibración. En ella es posible recibir los datos 
de calibración desde el dispositivo electrónico de medición, calcular los coeficientes óptimos de 
calibración y retransmitirlos de vuelta hacia dicho dispositivo. 

 

File (archivo): Muestra un menú con todos los comandos relacionados con los archivos 
topográficos. 
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 File > New Cave (nueva cavidad) 

 Borra todos los datos y los dibujos. Sirve para iniciar una nueva topografía desde cero, 
sin relación con otros datos topográficos anteriores. 

 File > New (nuevo) 

 Borra los datos y los dibujos, pero mantiene el resto de la topografía de la cavidad, 
incluyendo los últimos datos recientes, para uso posterior. Sirve para iniciar el 
levantamiento de una nueva zona dentro de la misma cavidad, que será almacenada en 
un archivo diferente. 

 File > Open… (abrir…) 

 Da paso a un diálogo que permite abrir un archivo existente. El contenido de ese 
archivo se mostrará como el nuevo conjunto de datos y dibujos en curso. Todos los 
demás archivos en el mismo directorio serán abiertos también y mostrados como 
formando parte de la cavidad. 

 File > Save (guardar) 

 Guarda los datos y dibujos en curso en el archivo original. 

 File > Save As… (guardar como…) 

 Abre un diálogo que permite guardar los datos y dibujos actuales en un nuevo archivo, 
con un nombre y una ubicación (directorio) específicos. 

 

Import (importar): Muestra un submenú con la lista de conversores disponibles para la 
importación de los datos. 

 Import > Toporobot… 

 Abre un diálogo que permite seleccionar un archivo de texto en formato Toporobot que 
puede ser leído por PocketTopo. 

 

Export (exportar): Muestra un submenú con la lista de conversores disponibles para la 
exportación de los datos. 

 Export > Text… (exportar > texto…) 

 Abre un diálogo que permite guardar el archivo de datos actual en forma de texto 
tabulado. 

 Export > Toporobot… 

 Primero abre una ventana para especificar las opciones disponibles para realizar la 
exportación de los datos actuales a un archivo de texto con formato Toporobot; a 
continuación abre un diálogo para exportar (Save As…) el archivo. 

 Export > Therion… 

 Abre una ventana de diáologo para guardar los datos actuales en un formato de texto 
que puede ser leído por el programa de topografía subterránea Therion. 
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 Export > Outline… (exportar > planta…) 

 Permite guardar el dibujo actual de la planta (Outline) en formato DXF, el cual puede 
ser leído por la mayoría de los programas de edición gráfica (Illustrator…). 

 Export Side View… (exportar > alzado…) 

 Permite guardar el dibujo actual del alzado (Side View) en formato DXF. 

 

Undo (deshacer): Borra la acción del último comando ejecutado. Los comandos Undo/Redo 
(deshacer/rehacer) se aplican tanto a las operaciones de edición de datos como a las de 
dibujo. El programa retiene listas separadas de los pasos dados, tanto en la edición de datos, 
como en el dibujo de la planta y el dibujo del alzado, de manera que los comandos 
Undo/Redo actúen eficazmente en cada caso. El botón Undo de la barra inferior de 
herramientas (ver a continuación) tiene el mismo efecto. 

 

Redo (rehacer): Deja sin efecto la última acción Undo (deshacer) y restaura la situación 
anterior. El botón Redo de la barra inferior de herramientas tiene el mismo efecto. 

 

Exit (salir): Sirve para concluir el programa. Atención: el botón Close (cerrar), en forma de 
aspa, situado en la esquina superior derecha de la pantalla, no concluye la aplicación, sino que 
la pone en un segundo plano. 

 

3.2 Barra de herramientas 

La barra de herramientas situada en la parte inferior de la pantalla contiene siete botones en 
dos grupos. Los tres de la izquierda sirven para cambiar la vista actual; los otros cuatro son 
utilizados para cambiar la escala y para deshacer/rehacer acciones (Undo/Redo). 

 

Botón datos (data)  

Muestra las pantallas de datos. Pulsando sobre él, la vista cambia de la tabla de edición de 
datos topográficos a la ventana de introducción de coordenadas de los puntos de referencia. 

 

Botón poligonal (map)  

Muestra la representación esquemática (poligonal) de la cavidad, en planta. 

 

Botón dibujo (sketch)  

Muestra la pantalla de dibujo. Pulsando sobre él, la vista cambia del dibujo de la planta 
(Outline) al del alzado (Side View). 
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Botones Más y Menos  

Utilizados para variar la escala (Zoom) en las páginas de la poligonal (Map) y en las de dibujo 
(Sketch). Permiten modificar la escala gráfica entre 1:50 y 1:20.000, en 15 pasos 
consecutivos. 

En la página de datos (Data), estando seleccionado un campo que identifique una estación 
topográfica (From —desde— o To —hacia—), los botones “+” y “–” pueden utilizarse para 
incrementar o reducir el valor actual. 

 

Botones deshacer y rehacer (undo / redo)  

Deshacer (undo) elimina el efecto del último comando o acción ejecutada. Rehacer (redo) 
restablece dicho efecto. Los botones funcionan tanto en la edición de datos como en las 
operaciones de trazado de los dibujos de la planta y el alzado. El programa guarda por 
separado la relación de las últimas acciones de edición y las de dibujo. 

 

4. Pantalla de datos (Data View) 

Muestra una representación textual de los datos topográficos, mediante dos tipos de tablas: 
una para los datos de la poligonal y las mediciones auxiliares (distancias, rumbos e 
inclinaciones) y otra para los puntos de referencia (coordenadas de las entradas). 

   

 Datos Puntos de referencia 

Al tocar dos veces en una celda de la tabla, se activa un campo de texto en el cual es posible 
escribir y editar su contenido. Para que el dato quede almacenado es necesario tocar la tecla 

Intro (retorno)  después de escribir su valor. La tecla Tab (tabulador)  sirve también 
para almacenar el dato y activa automáticamente el siguiente campo a la derecha. 

Cuando la cueva consta de múltiples archivos almacenados en el mismo directorio, el 
contenido de los archivos adicionales es descargado y mostrado, pero no puede ser editado. 
Sólo es posible editar los datos del archivo actual y los nuevos que vayan siendo registrados. 

Las estaciones topográficas (puntos de topo) se identifican mediante el formato “a.b”, donde 
“a” y “b” son números. Normalmente “a” se utiliza para definir todos los puntos de una misma 
serie y “b” va incrementándose para cada nueva estación (1.1 – 1.2 – 1.3 …), aunque no es un 
requisito estricto. Lo que sí es obligatorio es que un determinado nombre “an.bn” sea único 
dentro de la topografía en curso (lo que incluye todos los archivos del directorio actual). 
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Todos los cambios realizados en los datos pueden anularse mediante el comando Undo 
(deshacer). 

 

4.1 Tiradas topográficas 

La poligonal topográfica se compone de “tiradas”. Cada tirada ocupa una fila de la tabla y 
contiene las siguientes columnas: 

 

From (desde) 

Punto desde el cual medimos (origen de la tirada). Si el campo está vacío, la tirada es 
ignorada por el programa. 

To (hacia) 

Punto hacia el cual medimos (final de la tirada). Si el campo está vacío, PocketTopo interpreta 
la tirada como una medición auxiliar de contorno (radial, anchura…). 

Dist (distancia) 

Distancia medida en metros entre los dos puntos. Si la distancia es cero, la fila es interpretada 
como una medición “hueca”, por ejemplo para iniciar una nueva serie. 

Decl (rumbo) 

Es el ángulo horizontal —azimut o rumbo—, medido con una brújula o un instrumento 
electrónico como el DistoX, expresado en las unidades seleccionadas en Options > Units 
(grados sexagesimales “°” o centesimales “g”). 

Incl (inclinación) 

Es el ángulo vertical medido con un clinómetro o un instrumento como el DistoX. Las 
inclinaciones descendentes (por debajo de la horizontal) son negativas y las ascendentes son 
positivas. Se expresa en las unidades seleccionadas en Options > Units (grados 
sexagesimales “°” o centesimales “g”). 

Comment (comentario) 

Es posible añadir un comentario de texto asociado a la tirada; en tal caso, aparece un asterisco 
(*) en la última casilla de la fila de datos. 
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4.2 Puntos de referencia 

La tabla de los puntos de referencia contiene los siguientes campos: 

 

ID 

Identificador (a.b) de la estación topográfica cuyas coordenadas figuran a continuación. 

East (Este) 

Coordenada Este en metros. 

North (Norte) 

Coordenada Norte en metros. 

Alt (altitud) 

Altitud absoluta —sobre el nivel del mar— en metros. 

Comment (comentario) 

Es posible añadir un comentario de texto; en tal caso, aparece un asterisco (*) en la última 
casilla de la fila. 

 

4.3 Menú contextual de la pantalla de datos (aparece al apoyar el lápiz unos segundos) 

Los menús contextuales de ambas tablas (tiradas y puntos de referencia) son prácticamente 
idénticos. Las excepciones se indican en la descripción siguiente… 

 

Comment (comentario) 

Abre un campo de texto para revisar y editar el comentario asociado a la fila actual de datos. 
Se accede también a él tocando dos veces en el último campo de dicha fila. La presencia de un 
asterisco (*) indica que hay un comentario asociado a esa fila de datos. 

Trip… (sesión topográfica) 

Disponible sólo para las tiradas. 
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Abre una ventana de diálogo que permite revisar y cambiar los ajustes de la sesión topográfica 
asociados a la fila actual. 

 

New Row (nueva fila) 

Inserta una fila vacía por encima de la fila actual. Si se acciona en el espacio vacío situado 
bajo la última fila, la nueva se abre por debajo de ella y no por encima. 

Delete Row (borrar fila) 

Borra la fila actual. En caso de borrado accidental, es posible recuperar los datos mediante el 
comando Undo (deshacer). 

Shot –> / Shot <– (visual –> / visual <–) 

Disponible sólo para las tiradas. 

Aplicado a una medición auxiliar de contorno (To = vacío), este comando la convierte en una 
tirada de poligonal; el punto topográfico de destino (To) cambia al siguiente ID que 
corresponda. Estando seleccionada la opción Reverse, los campos From y To se 
intercambian. Para propagar el cambio de numeración a las filas subsiguientes, hay que 
accionar el comando Renumber (renumerar). 

Aplicado a una tirada de poligonal, el comando invierte el sentido de la visual. La flecha al final 
del nombre indica el sentido resultante (en sentido avance “–>”, o en sentido salida “<–”). 

Renumber (renumerar) 

Disponible sólo para las tiradas. 

Reasigna los ID de todas las filas subsiguientes, a partir de la fila actual. Este comando se 
utiliza, fundamentalmente, para propagar los cambios realizados en una fila a todas las que 
vienen a continuación y contienen nuevas mediciones. Si, por cualquier motivo, se quiere 
restringir la renumeración a un determinado número de filas, hay que insertar una fila vacía al 
final del grupo, renumerar y, a continuación, borrar la fila vacía. 

Start here (empezar aquí) 

Inicia una nueva serie de medidas en la estación definida por la tirada o el punto de referencia 
actuales. Para ello inserta una nueva fila al final de la tabla, con el ID actual en el campo From 
y valor Next ID de la sesión actual (Trip) en el campo To. Los valores de la distancia y los 
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ángulos son cero. Esta tirada “hueca” no es estrictamente necesaria, pero es recomendable, ya 
que permite añadir un conjunto separado de mediciones auxiliares de contorno al primer punto 
de la nueva serie. Para mayor claridad, es importante escribir el nombre de la nueva galería o 
pasaje en el campo “comentario” de esta fila. 

El primer número del valor Next ID es automáticamente incrementado después de utilizar 
este comando. 

Continue here (continuar aquí) 

Disponible sólo para las tiradas. 

Se utiliza para continuar una serie preexistente, después de haber procesado otras series (por 
ejemplo, ramales de una galería). El comando ha de ser utilizado en la última estación 
topográfica de la serie existente. Inserta una fila nueva al final de la tabla, con el ID actual en 
el campo From, un campo To vacío y los valores de la distancia y los ángulos iguales a cero. 
Representa un medida auxiliar “hueca” que no tiene ningún efecto en la topografía, pero obliga 
a la numeración a continuar a partir del ID de la estación seleccionada. 

Copy (copiar) 

Copia el contenido textual del campo actual. 

Paste (pegar) 

Reemplaza el contenido del campo actual por el texto antes copiado. 

–> Map (poligonal) 

Cambia a la vista de la poligonal topográfica de la cueva, centrada en la estación topográfica 
de la fila actual de la tabla. 

–> Outline (planta) 

Cambia a la vista del dibujo en planta, centrada en la estación topográfica de la fila actual de 
la tabla. 

–> Side View (alzado) 

Cambia a la vista del dibujo en alzado, centrada en la estación topográfica de la fila actual de 
la tabla. 

 

5. Poligonal (Map View) 

Esta pantalla proporciona una visión de conjunto de la cavidad. Muestra todos los puntos de 
referencia y la poligonal, sin dibujos de contorno ni detalles. La parte correspondiente al 
archivo actual se muestra en rojo; el resto lo hace en negro. 

La escala del plano puede variarse con ayuda de los botones “+” y “–”. Además es posible 
desplazar el plano utilizando el lápiz-puntero o mediante los cursores de la PDA. 

En una línea de texto, al pie del dibujo, aparecen el desarrollo (L) y la profundidad (H) de la 
cueva, junto con la escala. Al tocar con el lápiz sobre un punto tpográfico, ese texto cambia y 
muestra el ID y las coordenadas del mismo. 



  12 

   

 

5.1 Menú contextual de la poligonal (Map View) 

–> Data (datos) 

Cambia a la vista de la tabla de datos y selecciona la fila correspondiente a la estación actual. 

–> Outline (planta) 

Cambia a la vista del dibujo en planta, centrada en la estación topográfica de la fila actual de 
la tabla. 

–> Side View (alzado) 

Cambia a la vista del dibujo en alzado, centrada en la estación topográfica de la fila actual de 
la tabla. 

 

6. Dibujo (Sketch View) 

Presenta la poligonal y las mediciones auxiliares de contorno y permite trazar directamente en 
la pantalla, con ayuda del lápiz, el dibujo de la planta y el alzado. La escala puede variarse con 
los botones “+” y “–”. Es posible desplazar el dibujo con ayuda del lápiz y con los cursores de 
la PDA. 

Esta parte ofrece dos posibles vistas: planta (Outline) y alzado (Side View). El alzado 
corresponde a una proyección vertical orientada en la dirección de la planta (no es un alzado 
desplegado). 

La escala se muestra en una línea de texto al pie del dibujo. Tocando con el lápiz en cualquier 
estación topográfica, el texto cambia para mostrar el ID y las coordenadas de dicha estación. 

Cualquier operación de trazado puede ser anulada mediante el comando Undo (deshacer). El 
programa guarda constancia por separado de las acciones Undo/Redo (deshacer/rehacer) 
para la planta y el alzado. 
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6.1 Útiles de dibujo 

Siete pictogramas situados en la parte superior de la pantalla sirven de ayuda para el trazado 
de los dibujos de la planta y el alzado. 

Mover  

Estando seleccionada esta herramienta, el lápiz sólo sirve para mover el dibujo en cualquier 
dirección y, manteniéndolo apoyado brevemente, para abrir el menú contextual. 

Color del trazado  

Estando seleccionado cualquiera de esos iconos, el lápiz se convierte en una herramienta de 
dibujo, pudiendo trazar líneas del color seleccionado. Para colorear un área (un lago, por 
ejemplo), es preferible hacer un rayado que un relleno compacto, ya que así se reduce la 
memoria necesaria. 

Para desplazar el dibujo no es necesario cambiar a la herramienta “mover” , ya que es 
posible hacerlo iniciando un desplazamiento a partir de cualquiera de las cuatro esquinas de la 
pantalla, señaladas con unas flechas, o utilizando los cursores de la PDA. 

Borrar  

Convierte el lápiz en un borrador, de manera que al tocar el cualquier línea previamente 
dibujada es posible borrarla. En caso hacer un borrado accidental, es posible recuperar la línea 
eliminada por medio del comando Undo. 

Como en el caso anterior, para desplazar el dibujo no es necesario cambiar a la herramienta 

“mover” , ya que es posible hacerlo iniciando un desplazamiento a partir de cualquiera de 
las cuatro esquinas de la pantalla señaladas con unas flechas, o utilizando los cursores de la 
PDA. 
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6.2 Menú contextual del dibujo en planta (Outline) 

Show Grid (mostrar cuadrícula) 

Muestra una cuadrícula bajo el dibujo. Según la unidad de distancia escogida en los ajustes, el 
tamaño de cada celda es de 1 m ó 5 pies. Cuando la escala es igual o superior a 1:1.000, la 
cuadrícula desparece. 

Show All (mostrar todo) 

Cuando está seleccionado muestra los datos topográficos de toda la cavidad. En caso contrario, 
sólo aparecen los datos correspondientes a la sesión topográfica en curso. 

Xsection | (sección transversal vertical) 

Utilizado en una estación topográfica, prepara el dibujo de una sección transversal vertical 
correspondiente a dicha estación. El siguiente toque con el lápiz define la posición en el dibujo 
en la cual se trazará la sección transversal. En ese punto aparece una copia de la estación y 
una proyección apropiada de todas las mediciones transversales. Cualquier sección transversal 

errónea puede ser eliminada mediante el comando Undo o mediante la herramienta . 

–> Data (datos) 

Cambia a la vista de la tabla de datos y selecciona la fila correspondiente a la estación actual. 

–> Map (poligonal) 

Cambia a la vista de la poligonal, centrada en la estación topográfica de la fila actual de la 
tabla. 

–> Side View (alzado) 

Cambia a la vista del dibujo en alzado, centrada en la estación topográfica de la fila actual de 
la tabla. 

 

6.3 Menú contextual del alzado (Side View) 

Flip (invertir la orientación del alzado actual) 

Invierte la orientación del alzado que se está dibujando, de izquierda a derecha o viceversa. 
No es posible deshacer la acción mediante Undo; para volver a la orientación original basta 
accionar nuevamente este comando. 

Flip All (invertir todo el alzado) 

Invierte la orientación del alzado que se está dibujando y de todo el trazado que vendrá a 
continuación, de izquierda a derecha o viceversa. No es posible deshacer la acción mediante 
Undo; para volver a la orientación original basta accionar nuevamente este comando. 

Show Grid (mostrar cuadrícula) 

Muestra una cuadrícula bajo el dibujo. Según la unidad de distancia escogida en los ajustes, el 
tamaño de cada celda es de 1 m ó 5 pies. Cuando la escala es igual o superior a 1:1.000, la 
cuadrícula desparece. 
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Xsection | (sección transversal vertical) 

Utilizado en una estación topográfica, prepara el dibujo de una sección transversal vertical 
correspondiente a dicha estación. El siguiente toque con el lápiz define la posición en el dibujo 
en la cual se trazará la sección transversal. En ese punto aparece una copia de la estación y 
una proyección apropiada de todas las mediciones transversales. Cualquier sección transversal 

errónea puede ser eliminada mediante el comando Undo o la herramienta . 

Xsection — (sección transversal horizontal) 

Utilizado en una estación topográfica, prepara el dibujo de una sección transversal horizontal 
correspondiente a dicha estación. El siguiente toque con el lápiz define la posición en el dibujo 
en la cual se trazará la sección transversal. En ese punto aparece una copia de la estación y 
una proyección apropiada de todas las mediciones transversales. Cualquier sección transversal 

errónea puede ser eliminada mediante el comando Undo o la herramienta . 

–> Data (datos) 

Cambia a la vista de la tabla de datos y selecciona la fila correspondiente a la estación actual. 

–> Map (poligonal) 

Cambia a la vista de la poligonal, centrada en la estación topográfica de la fila actual de la 
tabla. 

–> Outline (planta) 

Cambia a la vista del dibujo en planta, centrada en la estación topográfica de la fila actual de 
la tabla. 

 

7. Ajustes de la Sesión Topográfica (Trip Settings) 

Cada tirada está asociada a un conjunto de datos correspondientes a una sesión topográfica, 
cuyos valores son comunes a todas mediciones realizadas durante la misma sesión. 

Hay dos tipos de datos asociados a una sesión: los actuales y los guardados. Los actuales se 
utilizan para las nuevas mediciones; pueden ser revisados y modificados a través del comando 
Actual Trip (sesión actual) del menú principal. Los datos guardados están vinculados a 
mediciones memorizadas en un archivo. Pueden ser revisados y modificados, también, pero a 
través del menú contextual que permite ver los datos asociados a una de las tiradas 
correspondientes. 

 

7.1 Campos de la ventana Trip 

Date (fecha) 

Fecha en la que tuvo lugar la sesión topográfica. 

Decl correction (ajuste de la declinación) 

Valor de la declinación magnética, determinado manualmente. Se trata de la diferencia angular 
entre el Norte geográfico y el Norte magnético en la fecha dada. La declinación hacia el Este 
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tiene un valor positivo. La unidad angular utilizada es la que se haya seleccionado en el menú 
de ajuste de las unidades (Options > Units): grados sexagesimales “°” o centesimales “g”. 

El programa tiene en cuenta el valor de la declinación para realizar los cálculos de cada tirada. 

Next ID (siguiente identificador de estación topográfica) 

Disponible sólo en la información de la sesión topográfica actual (Actual Trip). 

Establece el siguiente ID que será utilizado por el comando Start Here (comenzar aquí) en la 
primera estación de una nueva serie. 

Comment (comentario) 

El campo “comentario” contiene información adicional acerca de la sesión topográfica, incluidos 
los nombres de los topógrafos, el estado de la cueva y otros. 

 

7.2 Comandos de la ventana Trip 

Cancel (cancelar) 

Descarta los cambios y cierra la ventana Trip. 

New (nuevo) 

Sólo disponible para la información de la sesión topográfica actual. 

Restaura los valores a la fecha actual y borra el comentario. 

OK (en la esquina superior derecha de la pantalla) 

Guarda los valores escritos en los diferentes campos y cierra la ventana Trip. Los datos son 
guardados en los ajustes de las preferencias de la sesión topográfica actual. Son 
independientes del archivo que esté abierto. Los datos de la sesión son guardados junto con el 
resto de la topografía cada vez que se accione el comando Save (guardar) o Save As… 
(guardar como…). 

 

8. Archivos Topo 

Todos los datos (mediciones y dibujos) se guardan normalmente en una representación binaria 
compacta en los denominados “archivos Topo”, con la extensión ‘.top’. A menos que se trate 
de una cavidad pequeña, es aconsejable dividir los datos en varios archivos. El programa 
puede mostrar toda la cueva a través de los archivos que la componen, pero sólo es posible 
modificar o extender los datos correspondientes al archivo actual. Para evitar problemas con 
este método, basta respetar ciertas reglas sencillas: 

- Cada cueva tiene que estar en un directorio propio, aunque sólo conste de un único 
archivo. 

- Dentro de cada directorio no deben existir datos duplicados. Por ejemplo, si se quiere 
hacer una copia de respaldo de una topografía, es mejor llevarla a un directorio diferente. 

En cavidades muy extensas, el número de archivos puede ser muy grande. En tal caso es 
recomendable sustituir los archivos antiguos arraigados por un único archivo que sólo 
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contenga los datos topográficos numéricos, y mantener únicamente separados los archivos en 
los cuales se esté trabajando en el presente. A tal fin hay que exportar todos los archivos 
individuales a un programa topográfico externo —algo que, de todas formas, conviene hacer—, 
e importar luego el archivo de datos unificados. Dicho archivo llevará la extensión ‘$.top’ por 
convención y se guarda en el directorio de la cavidad. Sirve como referencia pero nunca es 
abierto directamente y editado por el programa. Lo mismo sucede cuando se importa parte de 
una cueva desde unos datos topográficos preexistentes. 

Con el fin de evitar la pérdida de datos en caso de un fallo de hardware o de software, los 
datos actuales se almacenan continuamente en una memoria no volátil. Dos archivos 
(back1.top y back2.top) son creados alternativamente con el fin de evitar problemas cuando el 
sistema falla mientras se está escribiendo uno de ellos. Dichos archivos se borran 
normalmente cuando se cierra la aplicación, y la última configuración guardada es 
automáticamente restaurada si los archivos están presentes en el momento de arrancar la 
aplicación. Cuando hay una tarjeta de memoria insertada en la PDA, los archivos de 
salvaguarda (backup) son automáticamente copiados en ella también. 

 

9. Importación y Exportación 

Los comandos Import y Export se utilizan para convertir archivos topográficos existentes en 
archivos Topo y viceversa. Los comandos disponibles en la versión actual son los siguientes: 

 

9.1 Export > Text (exportar en formato texto) 

 

Crea un archivo de texto a partir de los datos topográficos, con la siguiente estructura: 

 

 

9.2 Export > Toporobot… (exportar en formato Toporobot) 

Crea un archivo de texto compatible con Toporobot a partir de los datos topográficos. Si la 
cueva consta de un único archivo Topo, el texto resultante puede ser importado directamente 
por el programa Toporobot. Si está dividida en varias partes, cada una de ellas deberá 
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exportarse por separado para luego ser unidas mediante un editor de texto. Toporobot no 
puede importar directamente varias partes separadas de una cavidad. 

 

9.3 Opciones de exportación en formato Toporobot 

El comando Export > Toporobot… abre una ventana de diálogo con varias opciones que 
afectan al resultado de la exportación: 

 Code Number (número de código) 

 Índice utilizado para identificar los ajustes de código para las estaciones exportadas. 
Hay que utilizar el número de un ajuste de código existente que coincida con el 
generado en la exportación, o utilizar el siguiente índice disponible. 

 Trip Number (número de sesión topográfica) 

 Índice utilizado para identificar los ajustes de la sesión para las estaciones exportadas. 
Hay que utilizar el siguente índice de sesión disponible. En caso de que haya varias 
sesiones asociadas a los datos exportados, serán numeradas consecutivamente a 
partir del índice dado. 

 Auto Declination (declinación automática) 

 Si se marca esta casilla, el código generado instruye al programa Toporobot para que 
relice una corrección automática de la declinación, de acuerdo con la fecha de la 
sesión topográfica y las coordenadas del punto de referencia. En caso contrario, el 
código utiliza la corrección manual de la declinación con el valor indicado en los 
ajustes de la sesión topográfica (Trip Settings). 

 Include Guidelines (incluir indicaciones) 

 Si se marca esta casilla, los datos correspondientes a las mediciones individuales de 
las secciones transversales (guidelines) son incluidos en forma de comentarios con 
cada estación. Esto no tiene influencia en los cálculos de Toporobot, pero permite 
reconstruir posteriormente las mediciones con todo detalle. Los valores de las 
mediciones de contorno compatibles con Toporobot (izquierda–derecha–techo–suelo) 
y calculados a partir de esas indicaciones son incorporadas al resultado topográfico. 

 

9.4 Exportación de gráficos 

Los dibujos de la planta y el alzado pueden ser exportados mediante los comandos Export > 
Outline (exportar planta) y Export > Side View (exportar alzado). Los archivos resultantes 
incluyen una representación gráfica de la poligonal y las medidas auxiliares y están escritos en 
formato DXF, compatible con la mayoría de las aplicaciones de dibujo vectorial (Illustrator…). 
La escala real del dibujo exportado es 1:500. Si se quiere aumentar o reducir esa escala hay 
que hacerlo desde el programa de dibujo. 

 

9.5 Import > Toporobot… (importación desde Toporobot) 

El programa puede leer datos topográficos de un archivo de texto con formato Toporobot. Tal 
archivo se almacena normalmente en un archivo “$.top” como salvaguarda. Para continuar 
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posteriormente el levantamiento topográfico se utilizarán nuevos archivos dentro del mismo 
directorio. 

 

10. Calibración (Calibration) 

Esta ventana permite llevar a cabo una calibración del instrumento electrónico de medida y 
analizar su calidad. El comando correspondiente se encuentra en el menú principal. 

Consiste, básicamente, en una tabla que muestra las medidas de calibración y su 
correspondiente análisis. Cada nueva medida recibida desde el instrumento electrónico 
conectado a PocketTopo es añadida automáticamente a la tabla. 

 

10.1 Tabla de calibración 

Contiene las siguientes columnas: 

Enable (Activar). La primera y la última columna muestran un asterisco (*) si la fila está 
activada. Los valores escritos en las filas desactivadas son ignoradas en el proceso de 
evaluación de la tabla. Para activar o desactivar una fila, basta con tocar con el lápiz 
sobre el campo correspondiente. Las filas desactivadas son útiles para excluir 
mediciones erróneas y afinar el análisis de la calibración. 

Group (Grupo). La segunda columna contiene la asignación de grupo. Los grupos se utilizan 
para definir conjuntos de mediciones de calibración realizadas en la misma dirección, 
pero tomadas con diferentes ángulos de volteo (roll) del aparato. Al tocar en el 
campo, se suceden tres posibles estados: ‘vacío’ – ‘A’ – ‘B’. Un campo vacío se utiliza 
para mediciones individuales. Una serie de ‘A’ o ‘B’ denota un grupo. Se debe utilizar 
‘A’ y ‘B’ alternativamente para definir cualquier grupo de números. Por defecto, las 
primeras 16 filas están configuradas como 4 grupos con 4 medidas cada uno. 

∆ Error estimado de los datos corregidos de esta fila. 

|G| Longitud corregida del vector de gravedad. 

|M| Longitud corregida del vector del campo magnético. 

α Ángulo formado por los dos vectores corregidos de gravedad y campo magnético. 
Debería ser prácticamente idéntico en todas las filas. “α” es igual a 90° – inclinación 
del campo magnético. 
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Gx El componente medido del vector X de la gravedad (dirección del láser). 

Gy El componente medido del vector Y de la gravedad (izquierda / derecha). 

Gz El componente medido del vector Z de la gravedad (arriba / abajo). 

Mx El componente medido del vector X del campo magnético (dirección del láser). 

My El componente medido del vector Y del campo magnético (izquierda / derecha). 

Mz El componente medido del vector Z del campo magnético (arriba / abajo). 

Decl El ángulo de azimut calculado a partir de los vectores corregidos (en la unidad 
seleccionada para las magnitudes angulares “°” o “g”). 

Incl El ángulo de inclinación calculado a partir de los vectores corregidos (en la unidad 
seleccionada para las magnitudes angulares “°” o “g”). 

Roll El ángulo de volteo (girando sobre el eje X) calculado a partir de los vectores 
corregidos (en la unidad seleccionada para las magnitudes angulares “°” o “g”). 

 

10.2 Comandos del menú calibración 

Bluetooth Idéntico al submenú Bluetooth del menú principal. 

New Borra la tabla de calibración para prepararla para una nueva calibración. 

Open… Muestra un diálogo para ‘abrir’ un fichero de calibración ‘.cal’ existente. 

Save… Muestra un diálogo para ‘guardar’ un fichero de calibración a un archivo ‘.cal’. 

Export… Muestra un diálogo para ‘guardar como…’ un fichero de calibración a un archivo de 
texto. 

Start Conecta con el dispositivo electrónico de medición y activa el modo de calibración 
(Calibration Mode On). Si falla la conexión, aparece un mensaje de error en la 
barra de estado. Para evitarlo, el Bluetooth debe estar correctamente configurado. 

Stop Conecta con el dispositivo de medición y desactiva el modo de calibración 
(Calibration Mode Off). Si falla la conexión, aparece un mensaje de error en la 
barra de estado. Para evitarlo, el Bluetooth debe estar correctamente configurado. 

Update Conecta con el dispositivo de medición y transfiere a su memoria no volátil los 
coeficientes de calibración. En la barra de estado aparece un gráfico que 
representa el progreso de la transferencia o, si ésta falla, un mensaje de error. 

Evaluate Recalcula la calibración a partir de los valores de la tabla, utilizando los ajustes de 
los campos Enable y Group. La barra de estado exhibe los siguientes valores: 

n Número efectivo de mediciones utilizadas para la calibración. 

i Número de iteraciones necesarias para lograr un resultado. 

∆ Error medio (RMS) estimado de todas las mediciones. Para que la calibración 
resulte buena, ese error debe tener un valor inferior a 0.5. 
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OK (En la esquina superior derecha de la pantalla). Cierra la calibración y retorna a 
las pantallas principales del programa. 

 

11. Cosas pendientes… 

Las siguentes funciones no han sido aún incorporadas, pero serán incluidas en una versión 
futura del programa: 

- Cuadrícula seleccionada por el usuario. 

- Corrección automática de la declinación. 

- Cierre de poligonales y análisis. 

- Lectura directa de las coordenadas de posición desde un GPS conectado. 

 

(Traducido y adaptado por Carlos Puch – julio de 2009) 

 


