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1 Bevezetés
PocketTopo  egy  barlangfelmérési  adatok  kezelésére  és  tárolására  szolgáló  alkalmazás  PDA-ra, 
Windows  Mobile  operációs  rendszerre  vagy  bármely  más  eszközre,  ami  tudja  futtatni  a  
.NET compact (dotnet) keretrendszert.
A program úgy lett  kifejlesztve,  hogy Bluetooth  kapcsolaton  keresztül  fogadni  tudja  a  mérési 
adatokat közvetlenül az elektronikus felmérő eszközből. A felmérési adatokat kézzel is be lehet írni, 
de a csatlakoztatott eszköz sokkal hatékonyabb.
Az  adatok  megjelenítése  a  három  tengelyű  elektronikus  kompasz/dőlésszögmérőre  van 
optimalizálva. Lehetővé teszi bármennyi keresztmetszet és segédpont felvételét tetszőleges irányban 
minden mérési pontról.
Az alkalmazás legfőbb előnye, hogy lehetővé teszi vázlatok rajzolását a PDA képernyőjén. A pontos 
felmérési adatok és a segédpontok használatával gyors és pontos vázlatokat készíthetünk.

2 Általános kezelőfelület
A felhasználói felület legfontosabb része egy eszközsor főmenüvel és néhány gombbal valamint a 
képernyő amin a háromféle nézet közül egy látható: az adat táblázat a szöveges mérési adatokkal, a 
térkép nézet ami a teljes barlang felmérését mutatja és a rajz vázlat az aktuális szakasz alaprajzával  
vagy az oldalnézetével.

2.1 Főmenü

A  főmenü  (Menu)  tartalmazza  a  leggyakrabban  használt 
funkciókat.

Bluetooth 

Megjeleníti a Bluetooth almenüt. 

Bluetooth ►Connect 

Felépíti  a  kapcsolatot  a  mérőműszerrel.  A  Bluetooth  portot 
helyesen be kell állítani a Port opcióknál.

Bluetooth ►Disconnect 

Bezárja a Bluetooth kapcsolatot. 

Bluetooth ►Auto 

Engedélyezi vagy tiltja az automatikus kapcsolódási módot. Ha engedélyezve van akkor a PDA 
időközönként megpróbálja újra felépíteni a megszakadt kapcsolatot.

Bluetooth ►Laser ON

Bekapcsolja a lézert a DistoX2-n.

Bluetooth ►Laser OFF

Kikapcsolja a lézert a DistoX2-n.

Bluetooth ►Measure

Elindít egy mérést a DistoX2-n.



Opciók 

Megjeleníti a beállítási almenüt a különböző konfigurációs parancsokkal.

Options ►Title Bar 

Engedélyezi  vagy tiltja  a  kijelzőn a  szokásos  címsor  megjelenítését.  Ha letiltja  akkor  az  ablak 
nagyobb lesz de nem lehet közvetlenül elérni a  Start menüt. (nem minden platformon működik 
azonosan) 

Options ►Smart 

Az ‘okos’ üzemmód be és kikapcsolása.  Smart módban a program három közel azonos mérést 
automatikusan felismer és egy új poligon mérésként létrehoz egy új poligon pontot. A visszamérés 
(Reverse) beállítással lehet a hátra mérést beállítani.

Options ►Reverse 

Átállítja az alapértelmezett mérésirányt visszamérésre (amikor az új pontból mérünk a már bemért 
pont felé). Az alapértelmezett mérésirányt (előre vagy hátra) használja az Smart mód, és a Shot 
parancs az adat ablak előugró menüjében.

Options ►Unit 

Beállítja a használt adatok mértékegységét a képernyőn és a módosításnál. A mértékegység váltás 
nincs hatással a tárolt adatokra. 

Options ►Unit ►360° 

Beállítja a szög mértékegységet fokra (teljes kör = 360°). 

Options ►Unit ►400g 

Beállítja a szög mértékegységet újfokra (grad) (teljes kör = 400g). 

Options ►Unit ►m 

Beállítja a hossz mértékegységet méterre.

Options ►Unit ►Feet 

Beállítja a hossz mértékegységet lábra.

Options ►Port 

Beállítja a soros portot a Bluetooth kapcsolatnál. A portnak meg kell egyeznie a Bluetooth manager-
ben beállított kimenő soros porttal.

Options ►Port ►None 

Törli a soros port beállítást és letiltja a Bluetooth kapcsolatot.

Options ►Port ►COM0 - COM9 

Megadja a Bluetooth kapcsolat port számát.

Actual trip… 

Megnyitja a aktuális mérési sorozat (trip) beállító ablakot. Ezeket a beállításokat használja az új 
mérés.



Calibration… 

Megnyitja a kalibrálási ablakot. Ez a panel lehetővé teszi a kalibrációs adatok gyűjtését, kiszámolja 
az optimális kalibrálási együtthatókat és visszaírja a műszerbe.

File 

Megnyitja az állomány kezelő almenüt. 

File ►New Cave 

Törli  az  összes  adatot  és  rajzot.  Új  felmérés  kezdésénél  használjuk amikor  nincsenek meglévő 
kapcsolódó adatok. 

File ►New 

Törli az aktuális adatokat és rajzokat, de megtartja háttérben a barlang többi adatát beleértve az 
előzőleg elmentett aktuális adatokat további felhasználásra. Új rész felmérésénél használjuk amit 
külön állományba szeretnénk elmenteni ugyan abban a barlangban.

File ►Open… 

Létező  állomány  megnyitására  szolgáló  ablakot  nyit  meg.  Az  állomány  tartalma  betöltődik  új 
aktuális adatként és rajzként. Minden más állomány tartalma a adott könyvtárból a barlang további 
részeként látható lesz a háttérben.

File ►Save 

Elmenti az aktuális adatokat és rajzokat az eredeti állományba.

File ►Save As… 

Megnyitja az új állomány mentésére szolgáló ablakot, hogy egy új néven elmenthessük az adatokat 
és a rajzokat.

Import 

Megnyitja az almenüt a rendelkezésre álló beolvasási konverziókkal.

Import ►VisualTopo… 

Az állomány megnyitás ablak segítségével beolvas egy VisualTopo formájú szöveges állományt.

Import ►Toporobot… 

Az állomány megnyitás ablak segítségével beolvas egy Toporobot formájú szöveges állományt.

Export 

Megnyitja az almenüt a rendelkezésre álló kimeneti konverziókkal.

Export ►Graphics… 

Megnyitja  a  grafika  export  párbeszédablakot  amiben  az  alaprajzot  és  az  oldalnézetet  vonalas 
ábraként elmenthetjük DXF formátumban. 

Export ►3D… 

A ‘mentés másként’ párbeszéd ablak segítségével létrehoz egy mérési poligonra és részletpontokra 
alapozott térbeli felület állományt DXF formátumban.



Export ►Text… 

A  ‘mentés  másként’  párbeszéd  ablak  segítségével  létrehoz  egy  táblázatos  formájú  szöveges 
állományt az aktuális mérési adatokból.

Export ►Therion… 

A ‘mentés másként’ párbeszéd ablak segítségével létrehoz egy Therion programmal beolvasható 
szöveges állományt az aktuális mérési adatokból és vázlatból.

Export ►VisualTopo… 

A ‘mentés másként’ párbeszéd ablak segítségével létrehoz egy VisualTopo programmal beolvasható 
szöveges állományt az aktuális mérési adatokból.

Export ►Toporobot… 

Megnyitja a Toporobot export párbeszédablakot amiben beállíthatjuk a kimenet főbb paramétereit 
és létrehozhatjuk a Toporobot formátumú állományt. 

Loops

A hurokzárás almenüt nyitja meg. A program az azonos pontszámú mérési pontok alapján egyezteti 
az  egy  körhöz  tartozó  méréseket.  A hurokzárás  az  adatokra  nincs  hatással  csak  a  grafikán  a 
poligonmenetre.

Loops ►Close All

Minden (az aktuális és a háttérben lévő) mérésben megkeresi és bezárja a mérési hurkokat.

Loops ►Close Actual

Csak az aktuális mérésben lévő hurkokat zárja be.

Loops ►Close None

Megszünteti a hurkok zárását.

Undo 

Törli az utolsó kiadott parancs hatását. Visszavonás lehetséges az adattábla kezelésekor valamint a 
vázlatok készítésekor. Elkülönített Undo/Redo listák vannak az adat, az alaprajz és az oldalnézet 
ablakoknak. Az Undo gombnak az eszközsorban ugyan ez a hatása.

Redo 

Az  Undo hatásának  fordítottja:  visszaállítja  az  utolsó  változtatást.  A  Redo gombnak  az 
eszközsorban ugyan ez a hatása.

Exit 

Leállítja a programot. A PDA-n felül jobbra található  nem lép ki a programból csak háttérbe teszi 
azt.



2.2 Eszközsor 

A képernyő alján található eszközsor hét gombot tartalmaz két csoportban. A bal oldali  csoport 
szolgál az aktuális nézetablak beállítására. A többi gomb a nagyítás és az  Undo/Redo.

Adat gomb 

Megjeleníti az adat nézetet. A gomb ismételt megnyomásával lehet váltani a mérési és az alappont 
(bejárat koordináták) táblázat között.

Térkép gomb 

Megjeleníti a barlang (poligon) térképét.

Vázlat gomb 

Megjeleníti  a  vázlat  nézetet.  A gomb  ismételt  megnyomásával  lehet  váltani  az  alaprajz  és  az 
oldalnézet rajz között.

Plusz és Mínusz gomb 

Térkép  és  vázlat  nézetben  a  gombokkal  lehet  nagyítani  és  kicsinyíteni  (zoomolni).  Így  lehet 
változtatni a mérési adatok és a vázlatok megjelenítési léptékét 1:10 és 1:50000 között 20 lépésben. 
Ha az azonosító mező (From vagy To) van kiválasztva az adat nézetben akkor a gombok növelik 
vagy csökkentik az aktuális pontazonosító értékét.

Undo és Redo gomb 

Az  undo  törli  az  utolsó  kiadott  parancs  hatását.  A  redo  az  undo  fordítottja,  visszaállítja  a 
megváltoztatott állapotot. Az undo és a redo használható az adatok módosításánál az adat nézetben 
és a rajzolásnál a vázlat nézetben. Különálló Undo/Redo listák vannak az adat az alaprajz és az 
oldalnézetben. Az Undo és a Redo parancs a főmenüben ugyan így működik.

3 Adat nézet 
Az adat nézetben láthatjuk táblázatosan a felmérés adatait. Külön táblázata van a mérési adatoknak 
és az alappontoknak (bejárat koordináták). Szerkesztéshez a táblázatban kétszer kell megérinteni a 
megfelelő  mezőt.  Az  ENTER  billentyűvel  vagy  egy  másik  mezőre  való  érintéssel  lehet 
érvényesíteni a szerkesztést.  A megjegyzés beírását csak egy másik mezőre való érintéssel lehet 
befejezni (megjegyzésben lehet soremelés). A TAB  billentyű érvényesíti a változtatást és megnyitja 
szerkesztésre a következő mezőt. Egy barlang adatait több állományban tárolhatjuk egy könyvtáron 
belül,  adataikat  a  program  beolvassa,  megjeleníti  de  nem  módosíthatjuk.  Módosítani  csak  az 
aktuálisan  megnyitott  állományt  vagy  az  újonnan  létrehozott  állományt  lehet.   Az  azonosítót 
használja a táblázat a mérési pontok megkülönböztetésére. Az azonosító ‘a.b’ formátumú, ahol ‘a’ 
és ‘b’ számok. Az ‘a’ rendszerint a mérési sorozaton belül állandó és ‘b’ pedig minden pontnál egyel 
növekszik,  de  ez  nem  szigorú  követelmény.  Az  azonosítónak  egyedinek  kell  lennie  az  adott 
barlangban (minden állományban az adott könyvtáron belül). Minden változtatást az adatokon az 
Undo paranccsal visszavonhatunk.



3.1 Mért poligonok 

A mérési táblázat az alábbi oszlopokat tartalmazza:

From 

Az induló pont azonosítóját tartalmazza. Ha a mező üres 
akkor a mérést a program nem veszi figyelembe.

To 

A mérés  végpontjának  azonosítója,  Ha  üresen  hagyjuk 
akkor  a  mérést  részletpont  (keresztmetszet)  mérésként 
értelmezi a program, egyéb esetben poligon mérésként két 
azonosított pont között.

Dist 

A mért  távolság méterben (vagy lábban).  Ha a távolság 
nulla  akkor  a  sort  mint  egy  fiktív  mérést  értelmezzük, 
vagyis a két azonosító egy pontot jelent,  például egy új 
sorozat kezdetét. 

Azi 

A mért mágneses irányszög (azimut) a választott mértékegységben (fok vagy újfok). 

Incl 

A mért lejtésszög a választott mértékegységben (fok vagy újfok). Az emelkedő pozitív a csökkenő 
negatív előjelű.

Megjegyzés 

Az utolsó oszlopban lévő csillag (*) jelzi, hogy abban a sorban megjegyzés található. A megjegyzést 
a sorból előugró menü Comment parancsával vagy a mező dupla érintésével lehet szerkeszteni. A 
háttérben lévő mérési adatok sorát ‘-’ jelzi, ha van ott megjegyzés akkor ‘+’ jel.

3.2 Alappontok 

Az alappont táblázat az alábbi oszlopokat tartalmazza: 

ID 

A pont azonosítója amire a koordináták vonatkoznak.

East 

A  keleti  (jobbra)  koordinátája  a  pontnak  a  választott 
mértékegységben (m vagy láb).

North 

Az  északi  (képernyőn  fölfelé)  koordinátája  a  pontnak  a 
választott mértékegységben (m vagy láb).

Alt 

A pont magassága a választott mértékegységben (m vagy láb).



Megjegyzés

Az utolsó oszlopban lévő csillag (*) jelzi, hogy abban a sorban megjegyzés található. A megjegyzést 
a sorból előugró menü Comment parancsával vagy a mező dupla érintésével lehet szerkeszteni. A 
háttérben lévő mérési adatok sorát ‘-’ jelzi, ha van ott megjegyzés akkor ‘+’ jel.

3.3 Adat ablak előugró menü 

A menü tartalma mindkét táblánál nagyjából azonos. A különbségeket a leírásban jelezzük.

Comment 

Megnyitja  a  szövegmezőt,  hogy  megnézzük  és  szerkesszük  az  aktuális  sorhoz  tartozó 
megjegyzéseket. Ugyan ezt a hatást váltja ki a sorban az utolsó mezőre való dupla érintés. Egy 
csillag (*) jelzi a mezőben hogy megjegyzés van a sorhoz.

Trip… 

Csak poligon mérés ablakban van.
Megnyitja az aktuális sorhoz tartozó mérési sorozat (trip) adatokat tartalmazó ablakot megtekintésre 
és szerkesztésre.

New Row 

Beilleszt egy üres sort az aktuális fölé. A táblázat alatti üres területen használva hozzáfűz egy új 
üres sort a végére.

Delete Row 

Törli az aktuális sort. Az  Undo paranccsal lehet visszahozni a hibásan törölt adatokat.

Shot -> / Shot <-

Csak poligon mérés ablakban van.
Ha keresztmetszet mérésnél alkalmazzuk (To mező üres), akkor poligon mérésre váltja a sort a To 
mezőbe  beírva  a  soron  következő  azonosítót.  Ha  a  visszamérés  (Reverse)  üzemmód  be  van 
kapcsolva a  Shot parancs megfordítja a mérést megcserélve a  From és  To mezők tartalmát. Az 
újraszámozás (Renumber) parancsot lehet használni a további sorok pontszám változtatásához.
Ha poligon mérési sorban használjuk a parancsot akkor megfordítja a mérést.
A nyíl a parancs után azt jelzi, hogy mi lesz a művelet eredménye előre (->) vagy hátra (<-) mérés.

Renumber 

Csak poligon mérés ablakban van.
Újraszámozza az azonosítókat a minden további sorban az aktuális sortól kezdve. A parancsot főleg 
arra  használjuk,  hogy továbbvigyük  a  számozás  javítását  az  új  mérési  adatokra.  Ha  korlátozni 
akarjuk az újraszámozást egy adott részre akkor szúrjunk be egy üres sort a tartomány végére, és 
alkalmazzuk a Renumber parancsot az első sorban, majd töröljük az üres sort.

Start Here 

Elindít egy új mérési sorozatot a kijelölt referencia ponttól. A parancs egy új sort hoz létre a táblázat 
végére, a  From mezőbe a kijelölt azonosító kerül, a  To mezőbe pedig az aktuális Trip  Next ID 
adat, a távolság és a szögek nulla értéket kapnak. Ez a fiktív mérés nem feltétlenül szükséges, de 
lehetővé teszi egy független keresztmetszet mérést az első pontról az új sorozatban. Megegyezés 
szerint az új járat nevét ennek a sornak a megjegyzés rovatába írhatjuk. A sorozat számot a Next ID 
azonosítóban a parancs automatikusan egyel növeli.



Continue Here 

Csak poligon mérés ablakban van.
Az előzőleg feldolgozott mérési sorozat folytatásaként (pl. új ágaknál) használható. Beilleszt egy új 
sort a táblázat végére, a  From mezőbe beírja a kiválasztott pont azonosítóját, a  To mezőt üresen 
hagyja és a mérési adatokat feltölti nullával. Ez egy fiktív segédpont mérés aminek nincs hatása a 
mérésre de a kikényszeríti a sorszámozás folytatását ettől az azonosítótól.

Connect Here 

Csak poligon mérés ablakban van.
Létrehoz egy új sort nulla mérési értékekkel az aktuális azonosító és a kijelölt azonosítójú pont 
között. Ezzel összeköti a két azonosítót egy fizikai ponttá.

Copy

Bemásolja a szöveget az aktuális mezőből a másoló pufferbe.

Paste 

Felülírja az aktuális mező tartalmát a másoló puffer tartalmával.

> Map 

Átvált a térkép nézetre és a rajzot úgy mozgatja, hogy az aktuális sorral meghatározott mérési pont 
legyen a képernyő közepén.

> Outline 

Átvált az alaprajzi vázlat nézetre és a rajzot úgy mozgatja, hogy az aktuális sorral meghatározott 
mérési pont legyen a képernyő közepén.

> Side View 

Átvált az oldalnézeti vázlat nézetre és a rajzot úgy mozgatja, hogy az aktuális sorral meghatározott 
mérési pont legyen a képernyő közepén.

4 Térkép ablak 
A térkép nézet arra való, hogy áttekintést adjon az egész 
barlangról.  Láthatjuk  az  összes  alappontot,  poligont,  de 
nem  látjuk  a  részletpont  méréseket  és  a  vázlatokat.  Az 
aktuálisan megnyitott állományt pirossal, a többit feketével 
rajzolja  ki.  A  méretarányt  a  +  és  -  gombokkal  lehet 
változtatni.  A látható  részt  tollal  vagy a  készülék  kurzor 
gombjaival lehet mozgatni. A kép alján lévő szöveg sorban 
láthatjuk  a  barlang  (és  az  aktuális  rész)  hosszát  és 
mélységét  az  aktuális  méretaránnyal  együtt.  Ha 
megérintünk egy mérési pontot,  akkor annak azonosítója 
és koordinátái jelennek meg.

4.1 Térkép ablak előugró menü 

Screenshot... 

Elmenti az aktuális grafikus képet egy raszteres állományba. 



Options 

Az opciók almenüt jeleníti meg.

Options ►Show IDs 

Be/ki kapcsolja a pont azonosítók kijelzését. 1:1000-es méretaránytól kezdve a pont azonosító nem 
jelenik meg.

Options ►Thick Lines

Be/ki kapcsolja a vastag vonalas rajzolási módot. Nagyobb felbontású képernyőkön hasznos.

-> Data 

Mérési ponton aktiválva átvált adat nézetbe és kiválasztja az aktuális mérési pontot meghatározó 
sort. 

-> Outline 

Mérési ponton aktiválva átvált alaprajz nézetbe és az aktuális pontot teszi a kép közepére.

-> Side View 

Mérési ponton aktiválva átvált oldalnézet nézetbe és az aktuális pontot teszi a kép közepére.

5 Vázlat ablak 
A vázlat  ablakban  láthatjuk  az  összes  felmérési  adatot 
(poligon  és  részletpont  mérést)  és  rajzolhatunk 
közvetlenül  a  képernyőre.  A  méretarányt  a  + és  - 
gombokkal lehet változtatni. A látható részt tollal vagy a 
készülék  kurzor  gombjaival  lehet  mozgatni.  Két 
elkülönített  rajzolási  felület  van  az  alaprajznak  és  az 
oldalnézetnek.  Az  oldalnézet  a  poligonok  függőleges 
síkjára vetített, kiterített nézet.
A kép  alján  lévő  szöveg  sorban  láthatjuk  az  aktuális 
méretarányt  (közelítőleg).  Ha  megérintünk  egy  mérési 
pontot amikor a toll mozgatás módban van, akkor annak 
azonosítója és koordinátái jelennek meg.
Minden  rajzi  műveletet  vissza  lehet  vonni  az  Undo 
paranccsal.  Mind az alaprajzhoz,  mind az oldalnézethez 
tartozik egy különálló Undo/Redo lista.

5.1 Rajzeszközök 

Nyolc rajzolási és egy mozgatási mód közül választhatunk a képernyő felső részén található ikonok 
közül.

Mozgatás 

Ebben  a  módban  a  rajzot  mozgathatjuk  és  elérhetjük  az  előugró  menüt,  de  nem  rajzolunk  a 
képernyőre.

Toll szín 

Kiválasztja a rajzolás színét.  Bármilyen mozdulat a képernyőn adott  színű vonalat  eredményez. 



Terület  kitöltést  (sraffozást)  minimalizáljuk  a  memória  kímélése  érdekében.  A látható  terület 
mozgatásához a sarkokban található kis nyilakat kell megfogni.

Törlés 

A ‘radír’ módot választva minden megrajzolt vonal törölhető. Az Undo parancsot használhatjuk a 
hibásan törölt  vonalak visszaállítására.  A látható terület  mozgatásához a sarkokban található kis 
nyilakat kell megfogni.

5.2 Alaprajz előugró menü 

Screenshot... 

Elmenti az aktuális grafikus képet egy raszteres állományba. 

Options 

Megnyitja az opciók almenüt.

Options ►Show Grid 

Ha engedélyezett  akkor  a  rajz  hátterében egy rácsozatot  látunk.  A rács  mérete  1:10  és  1:75-ös 
méretarány között 0.2m (vagy 1 láb), 1:100 és 1:750-es méretarány között 1m (vagy 5 láb). 1:1000-
es méretaránytól kezdve a rács nem jelenik meg.

Options ►Show All 

Ha engedélyezett akkor az egész barlang összes mérési  adatát látjuk, ellenkező esetben csak az 
aktuális rajzét.

Options ►Show IDs 

Ha  engedélyezett  akkor  a  mérési  pontok  azonosítója  megjelenik  a  pont  mellett.  1:1000-es 
méretaránytól kezdve a pont azonosító nem jelenik meg.

Options ►Thick Lines 

Ha engedélyezett akkor vastag vonalakat rajzol. Nagyobb felbontású képernyőn így jobban látszik a 
rajz. 

XSection | 

Mérési ponton aktiválva az előugró menüt egy függőleges metszetrajzot készít elő az adott mérési 
ponthoz. A második toll érintés a rajzon a keresztmeszet helyét határozza meg. A mérési pontból 
kiinduló összes segédpont mérés (keresztmetszet mérés) egy másolata rajzolódik ki ide. A vetítés 
iránya az adott pontot meghatározó poligon iránya lesz. Hibás keresztmetszetet törölhetünk a az 
Undo paranccsal vagy a törlés móddal. 

-> Data 

Mérési ponton aktiválva átvált adat nézetbe és kiválasztja a pontot meghatározó adatsort.

-> Map 

Mérési ponton aktiválva átvált a térkép nézetre és a rajzot úgy mozgatja, hogy az aktuális mérési 
pont legyen a képernyő közepén.



-> Side View 

Mérési ponton aktiválva átvált a oldalnézetre és a rajzot úgy mozgatja, hogy az aktuális mérési pont 
legyen a képernyő közepén.

5.3 Oldalnézet előugró menü 

Screenshot... 

Elmenti az aktuális grafikus képet agy raszteres állományba. 

Flip 

Ha be van kapcsolva a parancs megfordítja az aktuális mérés futását bal   ̵̶  jobb-ról jobb   ̵̶  bal-ra. 
Nincs  Undo lehetőség  ehhez  a  parancshoz.  Használja  ugyan  ezt  a  parancsot  a  poligon  újbóli 
megfordításához.

Flip All 

Mint a Flip, de a sorban az összes további mérésre is alkalmazza a megfordítás műveletét. Nincs 
Undo lehetőség  ehhez  a  parancshoz.  Használja  ugyan  ezt  a  parancsot  a  poligonok  újbóli 
megfordításához.

Options 

Megnyitja az opciók almenüt.

Options ►Show Grid 

Ha engedélyetett  akkor  a  rajz  hátterében egy rácsozatot  látunk.  A rács  mérete  1:10  és  1:75-ös 
méretarány között 0.2m (vagy 1 láb), 1:100 és 1:750-es méretarány között 1m (vagy 5 láb). 1:1000-
es méretaránytól kezdve a rács nem jelenik meg. 

Options ►Show IDs 

Ha engedélyezett akkor a mérési pontok azonosítója megjelenik a pont mellett.

Options ►Thick Lines 

Ha engedélyezett akkor vastag vonalakat rajzol. Nagyobb felbontású képernyőn így jobban látszik a 
rajz. 

XSection | 

Mérési ponton aktiválva az előugró menüt egy függőleges metszetrajzot készít elő az adott mérési 
ponthoz. A második toll érintés a rajzon a keresztmeszet helyét határozza meg. A mérési pontból 
kiinduló összes segédpont mérés (keresztmetszet mérés) egy másolata rajzolódik ki ide. A vetítés 
iránya az adott pontot meghatározó poligon iránya lesz. Hibás keresztmetszetet törölhetünk a az 
Undo paranccsal vagy a törlés móddal.

XSection – 

Mérési ponton aktiválva az előugró menüt egy vízszintes metszetrajzot készít elő az adott mérési 
ponthoz. A második toll érintés a rajzon a keresztmeszet helyét határozza meg. A mérési pontból 
kiinduló összes segédpont mérés (keresztmetszet mérés) egy másolata rajzolódik ki ide. A vetítés 
iránya függőleges  lesz.  Hibás keresztmetszetet  törölhetünk a az  Undo paranccsal vagy a törlés 
móddal.



-> Data 

Mérési ponton aktiválva átvált adat nézetbe és kiválasztja a pontot meghatározó adatsort. 

-> Map 

Mérési ponton aktiválva átvált a térkép nézetre és a rajzot úgy mozgatja, hogy az aktuális mérési 
pont legyen a képernyő közepén.

-> Outline 

Mérési ponton aktiválva átvált a alaprajz nézetre és a rajzot úgy mozgatja, hogy az aktuális mérési 
pont legyen a képernyő közepén.

6 Trip (mérési sorozat) beállítások 
Minden méréshez tartozik egy mérési sorozat beállítás, ami a közös adatokat tartalmazza. Két fajta 
Trip  adat  létezik:  aktuális  és  tárolt.  A program az  aktuális  adatokat  rendeli  az  új  mérésekhez. 
Megnézni  és  megváltoztatni  a  főmenüben  az  Actual  Trip paranccsal  lehet.  A tárolt  adatok  a 
mérések egy csoportjához kötötten a mérési állományban tárolódnak. Megnézni és megváltoztatni a 
megfelelő sorra az adat nézet előugró menüjében lehet.

6.1 Trip ablak mezők 

Date 

A Trip (mérési sorozat) dátuma.

Decl Correction 

Egy  kézzel  beállított  mágneses  deklinációs  érték,  a 
mágneses és térképi északi irány közötti szög. Pozitív, ha a 
mágneses  észak  keletre  tér  el  a  térképi  északtól.  A 
mértékegysége megegyezik a főmenü opcióiban beállított 
szögmértékegységgel.  A  mérési  adatok  számításánál  a 
deklináció  hozzáadódik  az  irányméréshez  minden 
hozzárendelt sorban. Az automatikus deklináció számítás 
jelenleg nem érhető el.

Next ID 

Csak az aktuális Trip beállításnál.
Megadja milyen azonosítót kell használjon a  Start Here parancs a következő új mérésnél az új 
pontnak. A sorozatszámot egyel növeli minden használatkor a Start Here parancs.

Megjegyzés 

A megjegyzés  mező  további  információkat  tartalmazhat  a  mérésről,  mint  a  felmérők  nevei,  a 
barlang állapota stb.

6.2 Trip ablak parancsok 

Cancel 

Törli a változtatást és kilép a Trip ablakból.



New 

Csak az aktuális Trip beállításnál.
Visszaállítja az aktuális Trip adatait az aktuális dátumra és törli a megjegyzés mezőt.

OK (a képernyő jobb felső sarkában) 

Elmenti az aktuális Trip értékeiként a beállításokat és bezárja az ablakot. Ez független az aktuális 
állománytól. Az eltárolt Trip adatokat a Save vagy a Save As parancs menti a mérési adatokkal 
együtt a mérési állományba.

7 Topo állományok 
Minden mérési és rajzi adatot egy tömörített bináris un. Topo állományba ment el a rendszer ‘.top’ 
kiterjesztéssel.  Nagyon  kis  barlangok  kivételével  célszerű  a  barlang  részeit  külön  állományba 
menteni.  Annak  érdekében,  hogy láthassuk az  egész  barlangot  a  program mindig  beolvassa  az 
összes állományt,  de csak az aktuálisan megnyitottat  tudjuk változtatni.  A problémák elkerülése 
érdekében néhány egyszerű szabályt kell követni:
- Minden barlangnak egy külön mappát kell létrehozni, akkor is ha csak egy állományt tartalmaz.
- Nem szabad duplikálni adatokat a mappán belül, ha biztonsági mentést akarunk készíteni azt egy 
külön mappába kell tenni.

Nagyon  nagy barlangoknál  a  túl  sok  állomány  keletkezhet.  Ilyenkor  ajánlott  a  régi,  már  nem 
módosítandó állományokat egy, csak a mérési adatokat tartalmazó állományba összesíteni, és csak 
azokat hagyni külön amikkel még dolgozunk. Egy ilyen állomány elkészítéséhez ki kell exportálni 
minden különálló  állományt  egy külső barlangtérképező programba (egyébként  is  meg kell  ezt 
csinálni), és az összefűzött adatokat újra beimportálni. Az elkészült állomány neve egyezményesen 
‘$.top’,  és  be kell  tenni  a  barlang mappájába.  Ezt  csak  referenciának használjuk,  és  soha  nem 
nyitjuk meg közvetlenül szerkesztésre. Ugyan ez érvényes a barlang beimportált meglévő mérési 
adataira is. A $ állománynév biztosítja, hogy elsőnek kerüljön beolvasásra, és a további állományok 
már használhassák annak alappontjait.
 
Adatvesztés  elkerülése  érdekében  hardver  vagy  szoftver  hiba  esetére  az  aktuális  adatok 
folyamatosan mentésre kerülnek a nem felejtő memóriába. Két állományt (back1.top & back2.top) 
ír felváltva a program, hogy megelőzze a problémát ha a rendszer épp írás közben hibásodik meg. 
Ezek  az  állományok  alaphelyzetben  törlődnek  az  alkalmazás  bezárásakor,  és  az  utolsó  mentett 
állapot visszatöltődik automatikusan ha indításkor jelen vannak. Ha memória kártya is van a backup 
állományok a kártyára is átmásolódnak.



8 Import/Export 
Az import és export parancsokkal lehet átalakítani a meglévő méréseket és Topo állományokat.

8.1 Text Export 

Kiírja az aktuális mérési adatokat egy szöveges állományba az alábbi formátumban:

8.2 Toporobot Export 

Az aktuális  mérési  adatokat  egy Toporobot  kompatibilis 
állományba írja.

8.2.1 Toporobot Export Opciók 

Az  Export  Toporobot parancs  először  megnyit  agy 
párbeszédablakot  ahol  az  exportálás  lehetőségeit 
állíthatjuk be.

Save

Létrehozza  az  állományt  a  ‘mentés  másként’ 
párbeszédablak segítségével.

Cancel

Megszakítja a parancsot.

Add to Existing File 

Hozzáfűzi egy meglévő Toporobot állományhoz a mérés tartalmát.

[1]: 2008/07/24 0.27 "Trip megjegyzés"

1.0 200000.000 600000.000 700.000 "Alappont megjegyzés"

1.0 1.1 2.564 269.56 0.96 [1] 
1.0 1.1 2.563 268.35 0.91 [1] 

1.0 1.1 2.562 268.61 0.83 [1] 

1.1 1.237 226.37 7.48 [1] 

1.1 1.662 271.32 80.68 [1] 

1.1 0.930 267.67 84.97 [1] 

1.1 2.852 351.63 3.98 [1] 

1.1 1.2 4.045 317.14 20.84 [1] "Mérés megjegyzés"

1.1 1.2 4.039 317.24 20.90 [1] 

1.1 1.2 4.049 316.90 20.80 [1] 

1.2 0.842 178.86 0.60 [1] 

1.2 1.077 58.89 3.28 [1] 

1.2 0.404 297.86 82.82 [1] 

1.2 0.639 357.82 85.36 [1] 



Code Number 

Az exportált pontok kódjának azonosítására szolgáló szám. Olyan számot használjon ami megfelel 
egy korábbi exportált állomány felépítésének vagy használja a soron következő szabad  indexet.

Trip Number 

A Tripek azonosítására használt kód beállítására szolgáló szám. Használja a soron következő szabad 
indexet. Ha több Trip is van a mérésben akkor ettől a számtól kezdve kezdi a számozást.

Manual Declination 

...

Auto Declination 

Ha be van jelölve akkor a  generált kód utasítja a Toporobot programot az automatikus deklináció 
számításra az aktuális Trip dátuma és az alappont koordinátája alapján.

Include  Xsection Lines 

A segédpont (keresztmetszet) méréseket is beleírja a kódba.

Up/Down Vertical 

A függőleges részletpont mérések kódolását állítja be.

8.3 Grafika Export 

Az alaprajz és oldalnézet ablakokban készített vázlatokat ki tudjuk menteni DXF formátumban, 
vektoros ábraként. A rajzok tartalmazhatják a mérések vonalait is a rajz síkjába vetítve és a rajzi 
segédhálót is.
A rajz méretaránya  (Scale) alatt a PocketTopo azt érti, hogyha a rajzot milliméteres egységben 
kinyomtatjuk  akkor  a  megfelelő  méretarányú  ábrát  kapjuk.  Ha  egy méternek  egy rajzegységet 
akarunk  megfeleltetni  akkor  az  1:1000-es  méretarányt  kell  választani.  A  rajz  szövegeinek 
(pontszámok) méretét is ehhez igazítja.

8.3.1 Grafika export beállítási lehetőségek:

Save

Létrehozza  a  DXF  állományt  a  ‘mentés  másként’ 
párbeszédablak segítségével.

Cancel

Megszakítja a parancsot.

Write Plan

Alaprajzi képet exportálja a megadott utótaggal (Suffix).

Write Side

Oldalnézeti képet exportálja a megadott utótaggal.



Scale

A beállított skálának megfelelő méretezéssel készíti el a kimenetet.

Use Grid

A képernyőn megjelenő méretezéssel készíti el a kimenetet.

Include

A bejelölt rajzelemeket teszi bele a kimeneti állományba:

Shots

Mérési poligon

Xsections

Keresztmetszet mérések (segédpontok)

Labels

Pontszámok

Grid

Négyzetháló

All Data

Minden háttérben lévő mérési adat

Separate Layers

A bejelölteket külön rétegre teszi.

All Colors

A rajz minden színét is külön rétegre teszi.



9 Kalibráció 
A kalibrációs  ablakban  van  lehetőségünk  a  mérőműszer 
beszabályozására  és  a  minőség  ellenőrzésére.  A főmenü 
Calibration... parancsával  lehet  megnyitni.  A 
legfontosabb  része  egy  táblázat  amiben  láthatjuk  a 
kalibrációs  mérések  adatai  és  a  kiértékelésüket.  Az  új 
kalibrációs  mérések  automatikusan  műszerből 
hozzáadódnak a táblázathoz.

9.1 Kalibrációs táblázat 

A kalibrációs táblázat az alábbi oszlopokat tartalmazza:

Engedélyezés

Az első és utolsó oszlopban látható csillag (*) jelzi, hogy a 
sor  engedélyezett.  A  letiltott  sorokban  lévő  adatokat 
figyelmen  kívül  hagyja  a  program  a  számoláskor.  Az 
engedélyezett/tiltott állapotot a mező érintéssel válthatjuk. Tiltással lehet kizárni a hibás méréseket 
a számításkor, megpróbálva javítani a kalibráláson.

Csoport 

A második oszlop a csoport hozzárendelés. Csoportokat használunk a pontosan azonos irányban 
különböző elforgatási szögekkel végzett mérések megjelölésére. A mező megérintésére ciklikusan 
változik a három lehetséges érték között: üres, ‘A’ vagy ‘B’. Az üres sor egyedi mérést jelöl. ‘A’ és  
‘B’ egy csoportba tartozó sorozatokat jelent.  ‘A’ és ‘B’ felváltva használható tetszőleges számú 
csoport tagra. Alapértelmezésként az első 16 sor van beállítva 4 csoport 4 mérésének.

Δ 

A sor helyesbített adatainak becsült hibája.

|G| 

A helyesbített gravitációs vektor hossza. 1 körülinek kell lennie.

|M| 

A helyesbített mágneses mező vektor hossza. 1 körülinek kell lennie. 

α 

A két helyesbített vektor, a mágneses és a gravitációs közötti szög. Közel azonosnak kell lennie 
minden sorban. α egyenlő 90° - mágneses inklináció (mágneses lehajlás). Budapesten α  ≈ 25°.

Gx 

A mért gravitációs vektor X összetevője (lézer irány).

Gy 

A mért gravitációs vektor Y összetevője (jobbra/balra).



Gz 

A mért gravitációs vektor Z összetevője (fel/le).

Mx 

A mért mágneses vektor X összetevője (lézer irány).

My 

A mért mágneses vektor Y összetevője (jobbra/balra). 

Mz 

A mért mágneses vektor Z összetevője (fel/le). 

Azi 

A helyesbített irányszöge a mérésnek a beállított mértékegység szerint. 

Incl 

A helyesbített dőlésszöge a mérésnek a beállított mértékegység szerint. 

Roll 

A helyesbített  elforgatási  szöge  (az  X  tengely  körüli  körülfordulás)  a  mérésnek  a  beállított 
mértékegység szerint.

9.2 Kalibrációs menü parancsok 

Bluetooth 

A Bluetooth almenü megegyezik a főmenüben lévővel.

New 

Törli a kalibrációs táblázatot egy új kalibrációs mérés előkészítéséhez. 

Open… 

Megnyitja  az  állomány  megnyitására  szolgáló  ablakot,  hogy 
beolvashassunk egy létező kalibrációs adatot  egy ‘.cal’ állományból. 

Save… 

Megnyitja az új állomány mentésére szolgáló ablakot, hogy elmenthessük az aktuális kalibrációs 
adatokat  egy ‘.cal’ állományba.

Export… 

Megnyitja az új állomány mentésére szolgáló ablakot, hogy elmenthessük az aktuális kalibrációs 
adatokat  egy szöveges állományba.

Start 

Elindítja  a  kalibrációs  módot  a  műszeren.  Kapcsolódási  hibánál  a  hibaüzenet  az  állapotsorban 
jelenik meg. A Bluetooth kapcsolatnak működnie kell a parancs kiadásakor.



Stop 

Kikapcsolja a kalibrációs módot a műszeren. Kapcsolódási hibánál a hibaüzenet az állapotsorban 
jelenik meg. A Bluetooth kapcsolatnak működnie kell a parancs kiadásakor.

Update 

Kapcsolódik a DistoX műszerhez és átküldi annak megmaradó memóriájába a kalibrációs értékeket. 
Az átvitel folyamatát vagy a hibaüzenetet az állapot sorban láthatjuk. A Bluetooth kapcsolatnak 
működnie kell a parancs kiadásakor.

NL

Be/ki kapcsolja a nemlineáris hiba figyelembe vételét a számításnál és az átküldésnél.
Egyes  DistoX2  műszereknek  a  gyorsulás  érzékelői  jelentős  nemlineáris  hibával  terheltek.  Ez 
csökkenti a mérési pontosságot és ennek kiküszöbölésére szolgál az opció. Meglévő kalibrációs 
adatoknál is át lehet kapcsolni, nem szükséges újramérni a kalibrációt. 
Ne használja ezt az opciót DistoX1 műszernél vagy 2.3 verziószámú firmware alatt!

Extra

Különleges kalibrációs lehetőségek.

Extra ►Initial

Feltölti egy ideális mérési adatsorral a táblázatot.

Extra ►Read

Kiolvassa a kalibrációt a műszerből. Az átvitel folyamatát vagy a hibaüzenetet az állapot sorban 
láthatjuk.

Extra ►Result

Megmutatja a kalibrálási értékeket.

Evaluate 

Újraszámolja  a  kalibrációs  értékeket  a  táblázatból  az  engedélyezés  és  a  csoport  mező  aktuális 
beállításaival. Az alábbi értékek láthatók a állapot sorban:
n: A kalibrációban résztvevő mérések száma.
i: Az eredményt adó iterációk száma.
Δ: Az átlagos becsült hiba (RMS) az összes mérésre. 
A hibának 0.5-nél kisebbnek kell lennie a jó kalibrációhoz. 
nl: A nemlineáris hiba értékei. (NL opció esetén)

OK (képernyő jobb felső sarkában) 

Bezárja a kalibrációs ablakot és visszatér a fő ablakhoz. Nem menti el és nem törli a kalibrációs 
értékeket. A programból való kilépésnél erre külön rákérdez a rendszer.

10 Hiányzó funkciók 
Az alábbi funkciók még hiányoznak, de tervek szerint a program későbbi kiadásaiba bekerülnek:
 
-Felhasználó által választható koordináta-rendszer. 
-Automatikus deklináció korrekció.  
-Referencia pont koordinátáinak közvetlen beolvasása GPS készülékből.



11 Verzió történet

Támogatott nyelvek: Angol, Német, Francia, Lengyel és Szlovén

 
Új lehetőségek (V1.37)
 
Therion export javítás
Továbbfejlesztett oldalnézet vetítés
Rács beillesztés lehetőség a grafikus exportba
Újraszámozás javítás az előre és hátra mérésekben
Szlovén lokalizáció
1.371: Hiba javítása a Therion export-ban az előre és hátra mérésekben
1.371: DistoX2 kiszolgálás (távolság > 100m)
1.372: Nem-lineáris kalibrálás lehetőség (DistoX2)
1.372: Lézer távvezérlés (DistoX2)
 
 
Új lehetőségek (V1.36)
 
Egyszerű kör zárás
"Connect Here" parancs az adat legördülő menüben
Új méretarányok egészen 1:10 -ig (Régészeknek)
Lengyel lokalizáció
1.361: Hiányzó grafika menü javítás
1.362: Nagyítási probléma az 1:10 méretarányban megoldva
1.363: Therion export hiba javítva
1.363: Magasság számítási hiba megoldva
 
 
Új lehetőségek (V1.35)
 
Továbbfejlesztett grafika export
További rajzolási szín (narancs)
Az aktuális barlangrész hosszának és mélységének megjelenítése
Képernyő mentés lehetőség
Továbbfejlesztett VGA képernyő támogatás
 
 
Új lehetőségek (V1.34)
 
3D DXF állomány export
Előre és hátra mérés lehetősége
Opcionális pontszám kiíratás lehetősége a térkép és vázlat ablakban
Mérési pont információk és navigáció az 'azonosított' ponton
Vastag vonal (kényelmesebb a kisméretű VGA képernyőkön)
Továbbfejlesztett ablak kép a Windows-on (beleértve a Windows 7-et)
VisualTopo import és export
Továbbfejlesztett grafika export (pont számok és réteg beállítások)
Továbbfejlesztett Toporobot export



 
 
Új lehetőségek (V1.2)
 
Láb mértékegység opció (Option menü)
"Continue Here" az adat legördülő menüben
Therion export (Export menü)
Keresztmetszet vázlat lehetőség (Vázlat nézet legördülő menü)
Statisztika(barlang hossz és mélység) a térkép nézetben
Mérési pont információ (azonosító és koordináták) a megérintett pontra

Új lehetőségek (V1.1)

Újraszámítás parancs javítás

1.0

Első kiadás


