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1 Úvod 

PocketTopo je aplikácia na manipuláciu s mera skými dátami z jaskyne a ich archiváciu. Je ur ená preč č  
PDA s Windows Mobile alebo akéko vek iné zariadenie, ktoré podporuje .Net Compact Framework.ľ

Program prijíma zmerané dáta priamo z elektronického meracieho prístroja pripojeného 
prostredníctvom bezdrôtového spojenia Bluetooth. Zmerané hodnoty je tie  mo né zapísa  ru ne.ž ž ť č  
Samozrejme, prenos dát z pripojeného prístroja je omnoho efektívnejší.

Zobrazenie dát je navrhnuté pre trojosový elektronický kompas a sklonomer. Dovo uje pre ka dýľ ž  
merací bod neobmedzený po et meraní prie nych rezov a pomocných zámer v ubovo nom smere.č č ľ ľ

Hlavnou výhodou aplikácie je mo nos  kresli  ná rtky priamo na obrazovke PDA. Okam itáž ť ť č ž  
dostupnos  presných zameraných dát a mo nos  pou i  alšie pomocné zámery dovo uje rýchloť ž ť ž ť ď ľ  
kresli  presné ná rtky.ť č

2 Zoznámenie sa s u ívate ským rozhraním ž ľ
U ívate ské rozhranie pozostáva najmä z lišty nástrojov s hlavnou ponukou a nieko kých tla idiel až ľ ľ č  
plochy, ktorá mô e zobrazova  jeden z troch re imov: tabu ku dát zobrazujúcu zamerané dáta akož ť ž ľ  
text, mapu jaskyne, ktorá zobrazuje jasky u vcelku a ná rtok, ktorý ukazuje práve mapovaný priestorň č  
a dovo uje kresli  tak mapu ako aj rozvinutý rez.ľ ť

2.1 Hlavná ponuka 

Hlavná ponuka obsahuje nieko ko asto pou ívaných funkcií. ľ č ž

Bluetooth

Zobrazenie podponuky Bluetooth.

Bluetooth ▶Connect

Aktivácia pripojenia Bluetooth k meraciemu prístroju. Rozhranie Bluetooth musí by  správneť  
nastavené pomocou polo ky ž Port.

Bluetooth ▶Disconnect

Ukon enie pripojenia Bluetooth.č

Bluetooth ▶Auto

Povoli  alebo zakáza  re im automatického pripojenia. Ke  je re im automatického pripojeniať ť ž ď ž  
povolený PDA sa pokúša obnovi  pripojenie v pravidelných intervaloch pokia  bolo pripojenieť ľ  
prerušené.

Options

Zobrazi  podponuku mo ností konfigurácie s rôznymi konfigura nými príkazmi.ť ž č
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Options ▶Title Bar

Povoli  alebo zakáza  zobrazenie štandardnej titulnej lišty. Ke  je zobrazenie zakázané tak aktívnať ť ď  
oblas  obrazovky je o nie o vä šia, ale ponuka ť č č Start je priamo nedostupná.

Options ▶Smart

Zapnú  alebo vypnú  'chytrý' re im. Ke  je chytrý re im zapnutý, potom sú tri po sebe idúce v ur itejť ť ž ď ž č  
tolerancii rovnaké zámery vyhodnotené ako zámera na alší bod. Mo nos  ď ž ť Reverse definuje ič  
zámera je meraná vpred alebo vzad.

Options ▶Reverse

Nastavenie východzieho smeru zámer na vpred alebo vzad. Východiskový smer sa pou íva v chytromž  
re ime a pre príkaz ž Shot v kontextovej ponuke v re ime zobrazenia dát.ž

Options ▶Unit

Nastavenie jednotiek pre zobrazenie dát a ich editáciu. Zmena jednotiek nemá iadny vplyv naž  
ulo ené dáta.ž

Options ▶Unit ▶360°

Nastavenie uhlových jednotiek na stupne (celý kruh = 360°).

Options ▶Unit ▶400g

Nastavenie uhlových jednotiek na grády (celý kruh = 400g).

Options ▶Unit ▶m

Nastavenie d kových jednotiek na metre.ĺž

Options ▶Unit ▶Feet

Nastavenie d kových jednotiek na stopy.ĺž

Options ▶Port

Nastavenie sériového portu pre spojenie Bluetooth. Tento port musí zodpoveda  nastaveniuť  
výstupného sériového portu v správcovi Bluetooth.

Options ▶Port ▶None

Port pre Bluetooth bude nastavený na iadny a odpojí spojenie Bluetooth.ž

Options ▶Port ▶COM0 - COM9

Nastaví port pre Bluetooth na zvolené íslo portu.č

Options ▶Info…

Zobrazí informácie o aktuálnej verzii programu.

Actual trip…

Otvorí tabu ku s nastaveniami práve prebiehajúcej mera skej akcie. Nastavenia je mo né zmeni .ľ č ž ť  
Zmenené nastavenia sa pou ijú pre nové merania. ž

Calibration…

Otvorí tabu ku kalibra ných meraní. Táto tabu ka zobrazuje dáta z kalibra ných meraní a umo ujeľ č ľ č žň  
spusti  výpo et optimálneho kalibra ného koeficientu a zaznamena  ho spä  do meracieho prístroja.ť č č ť ť
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File

Zobrazí podponuku s príkazmi pre manipuláciu so súbormi.

File ▶New Cave

Vyma e všetky dáta a ná rtky. Pou íva sa vtedy, ke  sa za ína mapova  nová jasky a, ktorá nemáž č ž ď č ť ň  
súvis s u  zmeranými dátami.ž

File ▶New

Vyma e všetky aktuálne dáta a ná rtky ale ponechá zvyšok jaskyne v ítane predchádzajúcich dát prež č č  
neskoršie pou itie. Pou íva sa vtedy, ke  sa za ína s mapovaním novej asti jaskyne, ktorá má byž ž ď č č ť 
ulo ená vo zvláštnom súbore. ž

File ▶Open…

Zobrazí sa dialógové okno ‘File Open’, pomocou ktorého sa dá otvori  u  existujúci súbor. Obsahť ž  
súboru sa zobrazí ako nové aktuálne dáta a ná rtky. Všetky ostatné súbory v adresári otváranéhoč  
súboru sa tie  na ítajú a zobrazia sa ako zvyšok jaskyne.ž č

File ▶Save

Ulo í aktuálne dáta a ná rtky do pôvodného súboru.ž č

File ▶Save As…

Zobrazí sa dialógové okno ‘Save As’, pomocou ktorého je mo né ulo i  aktuálne dáta a ná rtky dož ž ť č  
iného súboru.

Import

Zobrazí sa podponuka so zoznamom dostupných importných filtrov.

Import ▶Toporobot…

Zobrazí sa dialógové okno ‘File Open’, ktoré umo uje otvori  súbor vo formáte Toporobot text ažň ť  
na íta  z neho dáta.č ť

Export

Zobrazí sa podponuka so zoznamom dostupných exportných filtrov.

Export ▶Text…

Zobrazí sa dialógové okno ‘Save As’, pomocou ktorého je mo né ulo i  aktuálne dáta vo formež ž ť  
tabu ky do textového súboru.ľ

Export ▶Toporobot…

Najprv sa otvorí tabu ka s mo nos ami ako exportova  aktuálne dáta do súboru vo formáte Toporobotľ ž ť ť  
text. Potom sa zobrazí dialógové okno ‘Save As’, pomocou ktorého je mo né vybra  súbor, do ktoréhož ť  
sa dáta ulo ia.ž

Export ▶Therion…

Zobrazí sa dialógové okno ‘Save As’, pomocou ktorého je mo né ulo i  aktuálne dáta do textovéhož ž ť  
súboru. Z tohto súboru je mo né do programu Therion naimportova  dáta i ná rty.ž ť č

Export ▶Outline…

Zobrazí sa dialógové okno ‘Save As’, pomocou ktorého je mo né ulo i  aktuálnu mapu do súboruž ž ť  
DXF. Súbor DXF je mo né naimportova  do vä šiny grafických editorov.ž ť č
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Export ▶Side View…

Zobrazí sa dialógové okno ‘Save As’, pomocou ktorého je mo né ulo i  aktuálny rozvinutý rez dož ž ť  
súboru DXF. Súbor DXF je mo né naimportova  do vä šiny grafických editorov.ž ť č

Undo

Zruší výsledok posledného vykonaného príkazu. Undo je možné použiť ako pre manipuláciu s dátami, 
tak i  v režime kreslenia náčrtku. Zoznamy operácií Undo/Redo sú zvlášť pre dátový režim, zvlášť pre 
režim kreslenia mapy a zvlášť pre režim kreslenia rozvinutého rezu. Tlačítko Undo v nástrojovej lište 
má ten istý význam.

Redo

Ruší posledné Undo a vracia zmenený stav. Tla ítko č Redo v nástrojovej lište má ten istý význam.

Exit

Ukon í aplikáciu. Tla ítko č č Close v pravom hornom rohu obrazovky neukon í aplikáciu ale ju ibač  
presunie do pozadia.

2.2 Nástrojová lišta 

Nástrojová lišta na spodku obrazovky obsahuje sedem tla idiel vo dvoch skupinách. avá skupinač Ľ  
troch tla idiel sa pou íva pre zmenu aktuálneho re imu. alšie štyri tla idlá sa pou ívajú na zmenuč ž ž Ď č ž  
mierky a pre Undo/Redo.

Tlačidlo dátový režim   
Prepne do dátového re imu. Opakované stlá anie tla idla prepína medzi tabu kou zmeraných zámer až č č ľ  
tabu kou referen ných bodov (zadaných súradnicami).ľ č

Tlačidlo mapa 

Prepne do re imu celkovej mapy. ž

Tlačidlo kreslenia   
Prepne do re imu kreslenia. Opakované stlá anie tla idla prepína medzi kreslením mapy až č č  
rozvinutého rezu. 

Tlačidlá plus a mínus    
Tla idlá č plus a mínus v re imoch mapy a kreslenia zmenšujú a zvä šujú mierku zobrazenia. Mierkaž č  
sa mô e meni  v 15 krokoch od 1:50 po 1:20000. ž ť
Tieto tla idlá sa mô u pou i  v dátovom re ime na zvýšenie alebo zní enie hodnoty ozna enia boduč ž ž ť ž ž č  
(v st pcoch ĺ From alebo To – Z bodu alebo Na bod).

Tlačidlá Undo a Redo    
Undo zruší výsledok posledného vykonaného príkazu. Redo ruší posledné Undo a vracia zmenený 
stav. Zoznamy operácií Undo/Redo sú zvlášť pre dátový režim, zvlášť pre režim kreslenia mapy a 
zvlášť pre režim kreslenia rozvinutého rezu. Príkazy Undo a Redo v hlavnej ponuke majú ten istý 
význam.
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3 Dátový re im ž
Dátový re im zobrazuje tabu ku dát merania v textovom tvare. Oddelené tabu ky sú pre zmeranéž ľ ľ  
zámery a pre referen né body (zadané súradnicami). Ke  na polí ko tabu ky klepnete dvakrát, otvoríč ď č ľ  
sa textové pole, kde mô ete zmeni  obsah polí ka tabu ky. Klávesou ž ť č ľ Return ulo íte zmeny a zavrietež  
edita né okno. Klávesou č Tab ulo íte aktuálne polí ko a otvoríte alšie vpravo.ž č ď
Ak sa mapovaná jasky a skladá z viacerých súborov v tej istej zlo ke, potom sa na íta a zobrazí ajň ž č  
obsah alších súborov, ale tieto dáta sa nedajú meni . Meni  mô ete iba dáta v aktuálne otvorenomď ť ť ž  
súbore a novo získané dáta.
Body zámer sú ozna ené pomocou identifika ných ísel. ísla majú formát 'a.b', kde 'a' a 'b' sú ísla.č č č Č č  
'a' je obvykle to isté pre všetky body v sérii (séria je as  polygónu, ktorá sa nevetví a ktorá nekri uječ ť ž  
samú seba) a 'b' sa zvä šuje o jednu pre ka dý alší mera ský bod, ale nie je to nevyhnutné.č ž ď č  
Identifika né íslo musí by  jedine né v celej aktuálnej jaskyni, to znamená vo všetkých súboroch vč č ť č  
aktuálnom adresári. 
Pomocou príkazu Undo sa všetky zmeny dajú vráti . ť
Poznámka: logika íslovania bodov a sérií vychádza z logiky programu Toporobot. PocketTopo ječ  
zadarmo, obsahuje ve a ve mi u ito ných funkcií, preto je lepšie prispôsobi  sa íslovaniu bodov aľ ľ ž č ť č  
rozdeleniu meraní na série, ne  program kvôli tomu odmieta . ž ť

Viac informácií o programe Toporobot

3.1 Tabu ka zmeraných zámer ľ
Tabu ka zámer sa skladá z nasledujúcich st pcov:ľ ĺ

From

Identifika né íslo mera ského bodu, z ktorého zámera vychádza (je meraná č č č z = from). Pokia  jeľ  
polí ko prázdne, riadok sa ignoruje.č

To

Identifika né íslo mera ského bodu, na ktorom zámera kon í (je meraná č č č č na = to). Pokia  je polí koľ č  
prázdne, dáta sú interpretované ako pomocná zámera z bodu v st pci ĺ From. V opa nom prípade je toč  
zámera medzi dvoma mera skými bodmi.č

Dist

Vzdialenos  v metroch. Ke  vzdialenos  je nula, tak riadok je interpretovaný ako 'fiktívna' zámera, oť ď ť č  
znamená, e obidva body sú toto né. Pou íva sa to napríklad pre prvý bod série, ktorá za ína na bodež ž ž č  
inej série (123.15 | 126.0 | 0 | ....)

Decl

Zmeraný azimut v jednotkách ur ených v nastavení č Unit (stupne alebo grády).

Incl

Zmeraný sklon v jednotkách ur ených v nastavení č Unit (stupne alebo grády). Klesajúce zámery majú 
sklon so znamienkom mínus.

Comment

Ak v poslednom st pci je nejaká poznámka, potom polí ko obsahuje hviezdi ku ('*').ĺ č č
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3.2 Tabu ka referen ných bodov ľ č
Tabu ka referen ných bodov sa skladá z nasledujúcich st pcov:ľ č ĺ

ID

Identifikácia bodu ur eného príslušnými súradnicami.č

East

Východná (horizontálna) as  súradníc bodu v metroch.č ť

North

Severná (vertikálna) as  súradníc bodu v metroch.č ť

Alt

Nadmorská výška bodu v metroch.

Comment

Ak v poslednom st pci je nejaká poznámka, potom polí ko obsahuje hviezdi ku ('*').ĺ č č

3.3 Kontextová ponuka v dátovom re ime ž
Kontextová ponuka v oboch tabu kách je skoro rovnaká. Výnimky sú uvedené v popisochľ  
jednotlivých príkazov.

Comment (poznámka)

Otvorí textové pole, aby sa dala skontrolova , prípadne upravi  poznámka v aktuálnom riadku. To istéť ť  
sa dá vyvola  dvojklikom na posledné polí ko riadku. Ak v poslednom st pci je nejaká poznámka,ť č ĺ  
potom polí ko obsahuje hviezdi ku ('*').č č

Trip… (mapovacia akcia)

Iba pre zámery. 
Otvorí tabu ku aby sa dali skontrolova  a zmeni  nastavenia mapovacej akcie platnej pre aktuálnyľ ť ť  
riadok.

New Row (nový riadok)

Vlo í nový prázdny riadok nad aktuálny. Ak pou ijete tento príkaz vo vo nom priestore podž ž ľ  
posledným riadkom, tak sa pridá nový riadok na koniec.

Delete Row (zmazať riadok)

Vyma e aktuálny riadok. Príkaz ž Undo vráti omylom vymazané dáta.

Shot -> / Shot <- (zámera)

Iba pre zámery.
Ke  sa pou ije pre pomocné zámery (ď ž To = prázdne), tak zmení pomocnú zámeru na zámeru polygónu 
a zmení obsah polí ka č To na íslo a šieho bodu. Ke  je navolená mo nos   tak pomocná zámera sač ď ĺ ď ž ť  
zmení na spätnú zámeru a vymenia sa polí ka č From a To. Pou ite príkaz ž Renumber aby sa zmena 
íslovania premietla do nasledujúcich riadkov.č

Ke  sa pou ije na zámeru polygónu, tak príkaz mení smer zámery medzi vpred a vzad.ď ž
Šípka na konci príkazu indikuje i výsledná zámera bude vpred (č ->)  alebo vzad (<-).
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Renumber (prečíslovať)

Iba pre zámery.
Priradí všetkým nasledujúcim riadkom nové ísla bodov vychádzajúc z aktuálneho riadku. Pou íva sač ž  
hlavne ke  je treba premietnu  zmenu vyvolanú vlo ením riadku s novou zámerou polygónu.ď ť ž
Pokia  je nutné obmedzi  pre íslovanie iba na ur ité riadky vlo te najprv na koniec riadkov, ktoré saľ ť č č ž  
majú pre íslova  prázdny riadok. Pou ite č ť ž Renumber na prvý riadok intervalu a potom odstrá teň  
prázdny riadok.

Start Here (východiskový bod novej série)

Za ne novú sériu meraní na východiskovom bode aktuálnej zámery alebo referen ného bodu. Príkazč č  
vlo í nový riadok na koniec tabu ky zámer s íslom aktuálneho bodu v polí ku ž ľ č č From a do polí ka č To 
sa vlo í nasledujúce íslo bodu ž č (Next ID) pre aktuálnu mera skú akciu. Vzdialenos  a smer budú nula.č ť  
Takáto 'fiktívna' zámera nie je nevyhnutne potrebná, ale odporú a sa ju ponecha , preto e dovo uje č ť ž ľ
urobi  samostatnú sadu pomocných zámer vychádzajúcich z prvého bodu novej série. Obvykle sa doť  
poznámky v tomto riadku uvedie ozna enie novej mapovanej chodby.č

íslo pred bodkou v mene bodu Č (Next ID) sa automaticky zvýši o jednu. 

Continue Here (pokračovať v už začatej sérii)

Iba pre zámery.
Pou íva sa vtedy, ke  chcete pokra ova  v u  za atej sérii potom, o ste dokon ili meranie inej sériež ď č ť ž č č č  
(napríklad odbo ky). Príkaz musíte pou i  na poslednom bode existujúcej série. Príkaz vlo í novýč ž ť ž  
riadok na koniec tabu ky s aktuálnym íslom bodu v polí ku ľ č č From a polí ko č To bude prázdne. 
Vzdialenos  a uhly budú nulové. To znamená e to bude 'fiktívna' pomocná zámera, ktorá nemá vplyvť ž  
na meranie ale spôsobí, e íslovanie bodov bude pokra ova  od ísla zvoleného bodu.     ž č č ť č

Copy (skopíruj)

Skopíruje obsah aktuálneho polí ka ako text do schránky. č

Paste (vlož)

Zamení obsah aktuálneho polí ka textom ulo eným v schránke.č ž

-> Map 

Prepne do re imu zobrazenia mapy a posunie polygón tak, aby sa bod ur ený aktuálnym riadkomž č  
posunul doprostred obrazovky.

-> Outline (mapa)

Prepne do re imu kreslenia mapy a posunie ná rtok tak, aby sa bod ur ený aktuálnym riadkomž č č  
posunul doprostred obrazovky.

-> Side View (rozvinutý rez)

Prepne do re imu kreslenia rozvinutého rezu a posunie ná rtok tak, aby sa bod ur ený aktuálnymž č č  
riadkom posunul doprostred obrazovky.

4 Re im zobrazenia mapy ž
Re im zobrazenia mapy sa pou íva vtedy, ke  chcete získa  preh ad o celej jaskyni. Zobrazia saž ž ď ť ľ  
všetky referen né body a zámery polygónu ale nie ná rty a pomocné zámery. as , ktorá sa na ítala zč č Č ť č  
aktuálneho súboru je ervená, ostatné asti jaskyne sú ierne.č č č
Mierka zobrazenia sa dá zmeni  pomocou tla idiel ť č Plus a Minus. Zobrazený polygón sa dá posúvať 
dotykovým perom alebo kurzorovými klávesami. 
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V riadku na spodku obrazovky je zobrazená informácia o celkovej d ke a prevýšení jaskyne spolu sĺž  
mierkou aktuálneho zobrazenia. Ke  kliknete na mera ský bod tak sa text zmení a zobrazí sa ísloď č č  
bodu a jeho súradnice. 

4.1 Kontextová ponuka v re ime zobrazenia mapy ž
-> Data

Prepne do dátového re imu a posunie kurzor na riadok odpovedajúci aktuálnemu mera skému bodu. ž č

-> Outline (kreslenie mapy)

Prepne do re imu kreslenia mapy a posunie ná rtok tak, aby aktuálny mera ský bod bol v stredež č č  
obrazovky. 

-> Side View (kreslenie rozvinutého rezu)

Prepne do re imu kreslenia rozvinutého rezu a posunie ná rtok tak, aby aktuálny mera ský bod bol vž č č  
strede obrazovky

5 Re im kreslenia mapy a rozvinutého rezu ž
Re im kreslenia mapy a rozvinutého rezu zobrazí zmerané dáta (zámery a pomocné zámery) a naž  
základe týchto zámer je mo né kresli  mapu jaskyne priamo na obrazovku PDA. Mierka zobrazenia saž ť  
dá zmeni  pomocou tla ítok ť č Plus and Minus. Zobrazený polygón sa dá posúva   dotykovým peromť  
alebo kurzorovými klávesami. 
Mapa a rozvinutý rez sa kreslia zvláš  ka dý vo svojom okne. ť ž
V textovom riadku dole sa zobrazuje aktuálne merítko. Ke  kliknete na jeden z mera ských bodovď č  
nástrojom pre posun ná rtku (šípka), text sa zmení a zobrazí sa íslo a súradnice bodu. Všetkyč č  
operácie je mo né vráti  príkazom ž ť Undo . Pre oba re imy, ako kreslenie mapy, tak kreslenie rezu, súž  
zvláštne zoznamy operácií Undo/Redo .

5.1 Nástroje v re ime kreslenia ž
V re ime kreslenia máte k dispozícii osem nástrojov, ktoré sa prepínajú malými tla idlami na hornomž č  
okraji oblasti pre kreslenie.

Move    (posunúť)

Týmto nástrojom mô ete pohybova  kresbou v oblasti pre kreslenie. Kontextová ponuka funguje, alež ť  
nie je mo né kresli . ž ť

Black, Gray, Brown, Blue, Red, Green         (čierna, šedá, hnedá, modrá, 
červená, zelená)

Farba 'pera', ktorým kreslíte ná rt. Akýko vek pohyb na obrazovke kreslí iaru v zvolenej farbe.č ľ č  
Plochy 'nevypl ujte', pou ite šrafovanie, zmenšíte tým podstatne nároky na pamä . ň ž ť
Kresbou je mo né posunova  ke  pohyb pera za nete na jednej zo štyroch malých šipiek v rohochž ť ď č  
alebo pomocou kurzorových kláves.

Delete     (gumovať)

Nástroj 'guma', ktorým mô ete zmaza  akúko vek nakreslenú iaru. Sta í klikn  perom blízko tejtož ť ľ č č ť  
iary. Príkazom č Undo vrátite omylom vymazanú iaru.č
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Kresbou je mo né posunova  ke  pohyb pera za nete na jednej zo štyroch malých šípiek v rohochž ť ď č  
alebo pomocou kurzorových kláves.

5.2 Kontextová ponuka v re ime kreslenia mapy ž
Show Grid (zobraz sieť)

Pokia  je tento príkaz aktivovaný, tak sa na pozadí kresby zobrazuje pravouhlá sie . Krok siete je buľ ť ď 
1 m alebo 5 stôp, v závislosti na zvolených jednotkách. Sie  sa nezobrazuje pri mierkach 1:1000 ať  
vä ších.č

Show All (zobraz všetko)

Pokia  je tento príkaz aktivovaný, tak sa zobrazujú zmerané dáta z celej jaskyne. Inak sa zobrazujú ibaľ  
aktuálne dáta.

XSection | (Priečny rez zvislý)

Tento príkaz sa musí pou i  na mera skom bode. Pripraví sa vertikálny rez obsahujúci priemetž ť č  
všetkých pomocných zámer z daného mera ského bodu na zvislú rovinu. alším kliknutím pera sač Ď  
definuje bod, kde bude rez umiestnený. V tomto bode bude príslušný mera ský bod obklopenýč  
pomocnými zámerami. Zlé umiestnenie sa dá odstráni  príkazom ť Undo alebo vymazaním.

XSection – (Priečny rez vodorovný – napríklad pre priepasť)

Tento príkaz sa musí pou i  na mera skom bode. Pripraví sa horizontálny rez obsahujúci priemetž ť č  
všetkých pomocných zámer z daného mera ského bodu na vodorovnú rovinu. alším kliknutím perač Ď  
sa definuje bod, kde bude rez umiestnený. V tomto bode bude príslušný mera ský bod obklopenýč  
pomocnými zámerami. Zlé umiestnenie sa dá odstráni  príkazom ť Undo alebo vymazaním.

-> Data

Prepne zobrazenie do dátového re imu. Kurzor bude v riadku s aktuálnym mera ským bodom.ž č

-> Map

Prepne zobrazenie do re imu zobrazenia mapy. Polygón jaskyne sa posunie tak, aby aktuálny bod bolž  
uprostred obrazovky.

-> Side View (režim kreslenia rozvinutého rezu)

Prepne zobrazenie do re imu kreslenia rozvinutého rezu. Kresba sa posunie tak, aby aktuálny bod bolž  
uprostred obrazovky.

5.3 Kontextová ponuka v re ime kreslenia rozvinutého rezu ž
Flip (prevrátit)

Iba na mera ských bodoch. Ke  tento príkaz aktivujete, tak sa aktuálny polygón vykreslí od prava doč ď  
ava namiesto od ava do prava. ľ ľ

Pre túto operáciu nie je príkaz Undo. Namiesto toho pou ite ten istý príkaz na tom istom bode eštež  
raz.

Flip All (prevrátit všetko)

To isté ako Flip ale aplikuje sa na všetky aktuálne vetvy z tej istej série.
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Pre túto operáciu nie je príkaz Undo. Namiesto toho pou ite ten istý príkaz na tom istom bode eštež  
raz.

Show Grid (zobraz sieť)

Pokia  je tento príkaz aktivovaný, tak sa na pozadí kresby zobrazuje pravouhlá sie . Krok siete je buľ ť ď 
1 m alebo 5 stôp, v závislosti na zvolených jednotkách. Sie  sa nezobrazuje pri mierkach 1:1000 ať  
vä ších.č

XSection | (Priečny rez zvislý)

Tento príkaz sa musí pou i  na mera skom bode. Pripraví sa vertikálny rez obsahujúci priemetž ť č  
všetkých pomocných zámer z daného mera ského bodu na zvislú rovinu. alším kliknutím pera sač Ď  
definuje bod, kde bude rez umiestnený. V tomto bode bude príslušný mera ský bod obklopenýč  
pomocnými zámerami. Zlé umiestnenie sa dá odstráni  príkazom ť Undo alebo vymazaním.

XSection – (Priečny rez vodorovný – napríklad pre priepasť)

Tento príkaz sa musí pou i  na mera skom bode. Pripraví sa horizontálny rez obsahujúci priemetž ť č  
všetkých pomocných zámer z daného mera ského bodu na vodorovnú rovinu. alším kliknutím perač Ď  
sa definuje bod, kde bude rez umiestnený. V tomto bode bude príslušný mera ský bod obklopenýč  
pomocnými zámerami. Zlé umiestnenie sa dá odstráni  príkazom ť Undo alebo vymazaním.

-> Data

Prepne zobrazenie do dátového re imu. Kurzor bude v riadku s aktuálnym mera ským bodom.ž č

-> Map

Prepne zobrazenie do re imu zobrazenia mapy. Polygón jaskyne sa posunie tak, aby aktuálny bod bolž  
uprostred obrazovky.

-> Outline (režim kreslenia mapy)

Prepne zobrazenie do re imu kreslenia mapy. Kresba sa posunie tak, aby aktuálny bod bol uprostredž  
obrazovky.

6 Nastavenie parametrov mera skej akcie č
Ka dá zámera obsahuje zárove  i dáta spolo né pre všetky merania tej istej mapovacej akcie – 'trip'.ž ň č
Existujú dva druhy takýchto dát: aktuálne a ulo ené (actual a stored). Aktuálne dáta sa pou ijú prež ž  
všetky novo zmerané dáta. Mô u sa skontrolova  a zmeni  pomocou príkazu ž ť ť Actual Trip v hlavnej 
ponuke. Ulo ené dáta sú pripojené ku skupine meraní ulo ených v súbore. Mô u sa skontrolova  až ž ž ť  
zmeni  pomocou kontextového menu v dátovom re ime na jednom z riadkov ulo eného merania.ť ž ž

6.1 Jednotlivé polia tabu ky parametrov mera skej akcie ľ č
Date (dátum)

Dátum mapovacej akcie.

Decl Correction (deklinácia)

Ru ne vlo ená hodnota deklinácie. To znamená uhlový rozdiel medzi geografickým a magnetickýmč ž  
severom. Deklinácia, v prípade e magnetický sever je východne od geografického severu, je kladnéž  
íslo. Pou ité jednotky odpovedajú jednotkám č ž Unit nastaveným v hlavnej ponuke. 
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Ke  sa dáta spracovávajú, tak táto korekcia sa pridá k azimutu ka dej zámery. ď ž
Upozornenie: Pozor aby sa deklinácia neuplatnila dvakrát, napríklad v PocketTopo a po druhý krát 
napríklad v Therione.

Next ID (nasledúce číslo bodu)

Iba v nastavení aktuálnej mapovacej akcie.
Ur uje aké íslo bodu bude pou ité v prípade príkazu č č ž Start Here pre prvý mera ský bod novej série.č  

as  ísla pred bodkou, ktorá ozna uje íslo série, sa zvýši o jedna pri ka dom pou ití príkazu Č ť č č č ž ž Start 
Here.

Comment (poznámka) 

ubovo ný text. ktorý obsahuje u ito né informácie o aktuálnej mapovace akcii (napr. mená mera ov)Ľ ľ ž č č

6.2 Príkazy v tabu ke parametrov mera skej akcie ľ č
Cancel

Zruší všetky zmeny a zavrie tabu ku parametrov mera skej akcie.ľ č

New

Iba v nastavení aktuálnej mapovacej akcie.
Obnoví  tabu ku parametrov mera skej akcie, dátum nastaví na aktuálny dátum a zma e poznámku.ľ č ž

OK (pravý horný roh obrazovky)

Ulo í aktuálne hodnoty a zavrie tabu ku parametrov mera skej akcie. Pre aktuálnu akciu sa dátaž ľ č  
ulo ia do nastavenia preferencií. Sú nezávislé od aktuálneho súboru. Ulo ené dáta akcie sa ulo iaž ž ž  
spolu s mera skými dátami pri alšom príkaze č ď Save alebo Save As.

7 Súbory s dátami – Topo 

Všetky dáta, merania aj ná rty, sú normálne ulo ené v kompaktnej binárnej forme v tzv. Topoč ž  
súboroch s koncovkou '.top'. Okrem ve mi malých jaský  sa odporú a rozdeli  meranie na viacľ ň č ť  
súborov. Program v dy na íta dáta zo všetkých súborov patriacich ur itej jaskyni, ale iba dáta vž č č  
aktuálnom otvorenom súboru sa mô u meni  alebo pridáva . Aby sa predišlo problémomž ť ť  
vyplývajúcich z tohto chovania programu, musia sa dodr ova  jednoduché pravidlá:ž ť
– pre ka dú jasky u musí by  osobitný adresár i pokia  je to iba jeden súbor,ž ň ť ľ
– iadne dáta nesmú by  v takomto adresári dvojmo. Ke  si chcete urobi  zálohu, skopírujte dáta dož ť ď ť  
iného adresára.

Súborov pre ve ké jaskyne mô e by  príliš ve a na to, aby sa s nimi dalo pracova . V takom prípadeľ ž ť ľ ť  
sa odporú a zlú i  staré a nemeniace sa súbory do jediného súboru, ktorý bude obsahova  ibač č ť ť  
mera ské dáta a ponecha  zvláš  iba súbory, s ktorými sa aktuálne pracuje. Aby ste urobili takýč ť ť  
archívny súbor, vyexportujte všetky súbory do programu pre spracovanie dát merania jaskyne (to 
ostatne tak i tak musíte urobi ) a potom naimportova  spä  všetky dáta do jediného súboru. Takýč ť ť ť  
súbor bude ma  obvykle meno ‘$.top’ a bude umiestnený v zlo ke jaskyne. Pou íva sa ako referen nýť ž ž č  
súbor ale nedá sa otvori  a meni . To isté sa stane, pokia  naimportujete do PocketTopo dáta z uť ť ľ ž 
existujúceho merania.

Aby sa predišlo strate dát v prípade havárie hardware alebo software sú aktuálne dáta automaticky 
ukladané do permanentnej pamäte. Aby sa predišlo problémom, ke  by došlo k systémovej chybe vď  
priebehu zápisu dát, striedavo sa zapisujú dva súbory (back1.top & back2.top). V normálnom prípade 
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sa tieto súbory vyma ú, ke  sa aplikácia ukon í. Ke  sú pri spustení aplikácie tieto súbory prítomné,ž ď č ď  
tak sa automaticky obnoví posledný ulo ený stav. Pokia  má zariadenie pamä ovú kartu, tak sa tietož ľ ť  
zálo né súbory zapisujú aj na u.ž ň

8 Import/Export 

Príkazy Import a Export sa pou ívajú pre konverziu medzi existujúcimi formátmi programov prež  
spracovanie merania jaský  a súbormi vo formáte Topo. V sú asnosti sú dostupné nasledujúceň č  
príkazy: 

8.1 Text Export 

Zapíše aktuálne dáta z merania do textového súboru s nasledujúcou štruktúrou:

[1]: 2008/07/24     0.27  Poznámka k akcii

     1.0        200000.000    600000.000   700.000    Poznámka k referen nému boduč

     1.0         1.1       2.564  269.56    0.96  [1]    
     1.0         1.1       2.563  268.35    0.91  [1]    
     1.0         1.1       2.562  268.61    0.83  [1]    
     1.1                   1.237  226.37   -7.48  [1]    
     1.1                   1.662  271.32   80.68  [1]    
     1.1                   0.930  267.67  -84.97  [1]    
     1.1                   2.852  351.63    3.98  [1]    
     1.1         1.2       4.045  317.14   20.84  [1]    Poznámka k mera skému boduč
     1.1         1.2       4.039  317.24   20.90  [1]    
     1.1         1.2       4.049  316.90   20.80  [1]    
     1.2                   0.842  178.86    0.60  [1]    
     1.2                   1.077   58.89    3.28  [1]    
     1.2                   0.404  297.86   82.82  [1]    
     1.2                   0.639  357.82  -85.36  [1]   

 

8.2 Toporobot Export

Aktuálne dáta z merania sa zapíšu do textového súboru kompatibilného s programom Toporobot. Keď 
jasky a pozostáva iba z jediného Topo súboru, výsledný textový súbor je mo né priamo naimportovaň ž ť 
do Toporobotu. Ke  je však jasky a rozdelená na nieko ko astí, ka dá as  musí by  exportovanáď ň ľ č ž č ť ť  
zvláš  a jednotlivé exporty musia by  spojené v textovom editore. Do Toporobotu sa nedáť ť  
naimportova  iba jedna z astí jaskyne.ť č

8.3 Mo nosti exportu vo formáte Toporobot ž
Príkaz Export Toporobot najprv otvorí tabu ku, kde sa dajú nastavi  niektoré parametre, ktoré majúľ ť  
efekt na výsledný export.

Code Number

Index, ktorý identifikuje nastavenie kódu pre exportované mera ské body. Pou ite íslo existujúcehoč ž č  
kódu, ktorý odpovedá meraniu, alebo pou ite prvý vo ný index.ž ľ
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Trip Number

Index, ktorý identifikuje nastavenie akcie (trip) pre exportované mera ské body. Pou ite prvý vo nýč ž ľ  
index akcie. Ke  sú s exportované dáta z nieko kých akcií, budú o íslované postupne za ínajúcď ľ č č  
daným indexom.

Auto Declination

Ke  sa táto mo nos  zaškrtne, tak sa vygeneruje kód, na základe ktorého Toporobot pou ijeď ž ť ž  
automatickú korekciu deklinácie vzh adom k danému dátumu akcie a súradniciam referen ného bodu.ľ č  
Inak sa pou ije manuálna korekcia deklinácie pod a nastavenia akcie.ž ľ

Include Guidelines

Ke  sa táto mo nos  zaškrtne, tak dáta z pomocných zámer sú obsiahnuté ako komentáre pri ka domď ž ť ž  
mera skom bode. To nemá iadny vplyv na výstupy z Toporobotu, ale dovo uje to neskôr presneč ž ľ  
rekonštruova  merania. Hodnoty stani enia kompatibilné s Toporobotom sa vypo ítajú z pomocnýchť č č  
zámer a sú obsiahnuté v exportovaných dátach.

8.4 Graphics Export (export do formátu DFX)

Ná rty urobené v re ime kreslenia ná rtov sa mô u exportova  pomocou príkazov č ž č ž ť Export Outline 
(export mapy) a Export Side View (export rozvinutého rezu). Všetky grafické prvky ná rtu vrátaneč  
grafickej reprezentácie zámer sa zapíšu do súboru vo formáte DFX. Tento formát vie importovať 
vä šina grafických editorov. Mierka výstupu je 1:500. Inú mierku mô ete získa  zodpovedajúcimč ž ť  
zmenšením alebo zvä šením v grafickom editore.č

8.5 Toporobot Import

Tento príkaz na íta mera ské dáta zo súboru 'Toporobot formatted text'. Tento import sa obvykle ulo íč č ž  
ako súbor s menom $.top. Nové merania sa budú uklada  ako nové súbory v tej istej zlo ke ť ž

9 Kalibrácia 

Tabu ka kalibra ných meraní umo uje skalibrova  merací prístroj (DistoX) a analyzova  kvalituľ č žň ť ť  
kalibrácie. Otvorí sa pomocou príkazu Calibration v hlavnej ponuke. Základnou as ou tabu ky súč ť ľ  
kalibra né merania a ich analýza. Nové kalibra né merania urobené na nepripojenom zariadení sa poč č  
pripojení automaticky pridajú do tabu ky.ľ

9.1 Tabu ka kalibra ných meraní ľ č
Tabu ka kalibra ných meraní sa skladá z nasledujúcich st pcov:ľ č ĺ

Enable (povoliť)

Ke  má by  riadok sú as ou kalibrácie, tak prvý a posledný st pec obsahuje hviezdi ku (‘*’) ď ť č ť ĺ č
Hodnoty v riadku, ktorý nemá by  sú as ou kalibrácie, sa pri výpo te ignorujú. Stav povoli /zakázať č ť č ť ť 
sa prepína kliknutím na príslušné polí ko. Zákaz riadku sa pou ije v prípade chybného merania aleboč ž  
pre prípad analýzy kalibrácie bez jedného merania alebo setu meraní.

Group (skupina)
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Druhý st pec obsahuje zna ku skupiny. Skupinou sa rozumie sada kalibra ných meraní urobených vĺ č č  
tom istom smere ale v dy s iným nato ením prístroja. Kliknutia na polí ko prepína medzi tromiž č č  
mo nými stavmi: prázdne, 'A' a 'B'. Prázdne polí ko zna í samostatné meranie. Séria ‘A’ alebo ‘B’ž č č  
ozna uje skupinu meraní. ‘A’ a ‘B’ sa pou ívajú striedavo a umo ujú tak definova  ubovo ný po etč ž žň ť ľ ľ č  
skupín. Normálne sa prvých 16 riadkov skladá zo 4 skupín po 4 meraniach ka dá.ž

Δ (delta)

Predpokladaná chyba korigovaných dát v tomto riadku.

|G|

D ka korigovaného gravita ného vektora. Mala by by  blízko jednej.ĺž č ť

|M|

D ka korigovaného vektora magnetického po a. Mala by by  blízko jednej.ĺž ľ ť

α

Uhol medzi korigovaným gravita ným vektorom a korigovaným vektorom magnetického po a.č ľ  
Hodnota je v jednotkách zvolených v nastavení Unit. Táto hodnota by sa pre všetky riadky nemala 
príliš líši .  sa rovná 90° mínus sklon magnetického po a.ť α ľ

Gx

X-ová as  zmeraného gravita ného vektoru (smer laseru).č ť č

Gy

Y-ová as  zmeraného gravita ného vektoru (v avo/vpravo).č ť č ľ

Gz

Z-ová as  zmeraného gravita ného vektoru (hore/dolu).č ť č

Mx

X-ová as  zmeraného vektoru magnetického po a (smer laseru).č ť ľ

My

Y-ová as  zmeraného vektoru magnetického po a (v avo/vpravo).č ť ľ ľ

Mz

Z-ová as  zmeraného vektoru magnetického po a (hore/dolu).č ť ľ

Decl

Uhol odchýlky (azimutu) vypo ítaný z korigovaných vektorov. Hodnota je v jednotkách zvolených vč  
nastavení Unit.

Incl

Uhol sklonu vypo ítaný z korigovaných vektorov. Hodnota je v jednotkách zvolených v nastaveníč  
Unit.

Roll

Uhol pooto enia okolo osi X vypo ítaný z korigovaných vektorov. Hodnota je v jednotkách zvolenýchč č  
v nastavení Unit.
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9.2 Príkazy v ponuke kalibrácie 

Bluetooth

To isté ako podponuka Bluetooth v hlavnej ponuke.

New

Vyma e tabu ku kalibra ných meraní a pripraví ju pre novú kalibráciu.ž ľ č

Open…

Zobrazí dialógové okno ‘File Open’ aby sa na ítali ulo ené kalibra né merania zo súboru ‘.cal’.č ž č

Save…

Zobrazí dialógové okno ‘Save As’ aby sa aktuálne kalibra né merania zapísali do súboru ‘.cal’.č

Export…

Zobrazí dialógové okno ‘Save As’ aby sa aktuálne kalibra né merania zapísali do súboru ‘.cal’.č

Start

Pripojí sa k meraciemu prístroju a prepne ho do kalibra ného re imu. V prípade, e sa spojenieč ž ž  
nepodarí nadviaza , objaví sa hlásenie o chybe. Príkaz vy aduje, aby Bluetooth bol správne nastavený.ť ž

Stop

Pripojí sa k meraciemu prístroju a vypne kalibra ný re imu. V prípade, e sa spojenie nepodaríč ž ž  
nadviaza , objaví sa hlásenie o chybe. Príkaz vy aduje, aby Bluetooth bol správne nastavený.ť ž

Update

Pripojí sa k meraciemu prístroju a zapíše vypo ítané kalibra né koeficienty do stálej pamäte. Vč č  
stavovom riadku sa zobrazí postup prenosu alebo hlásenie o chybe. Príkaz vy aduje, aby Bluetooth bolž  
správne nastavený.

Evaluate

Prepo íta kalibráciu z hodnôt v tabu ke s pou itím aktuálneho nastavenia polí č ľ ž Enable a Group. V 
stavovom riadku sa zobrazia nasledujúce hodnoty:
n: po et meraní pou itý pre výpo et kalibrácie,č ž č
i: po et iterácií nutných pre získanie výsledku,č
Δ: priemerná predpokladaná chyba (RMS) všetkých pou itých meraní.ž
Aby bola kalibrácia úspešná, hodnota chyby by mala by  menšia ako 0.5.ť

OK (horný pravý roh obrazovky)

Zavrie kalibra nú tabu ku a vráti aplikáciu do normálneho re imu.č ľ ž
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10 Chýbajúce funkcie 

Nasledujúce funkcie nie sú v sú asnosti sú as ou programu PocketTopo. V pláne je zahrnú  ich doč č ť ť  
budúcich verzií programu.

– u ívate om volite ný krok siete,ž ľ ľ
– automatická korekcia deklinácie,
– vyrovnanie uzavretých ahov a analýza chýb,ť
– priame na ítanie súradníc referen ných bodov z pripojeného prístroja GPS.č č
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